aboutsummaryrefslogtreecommitdiff
path: root/lang/pike76/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-04-17 18:51:07 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-04-17 18:51:07 +0000
commit1514ae323815f626efada825028e87da7f2fcf4d (patch)
treea1d52da2ea87dc423c5d08b7a3994b3df608c2aa /lang/pike76/Makefile
parent6809050924c26ef4c78e5e3ad1b948a53b92dcf2 (diff)
downloadports-1514ae323815f626efada825028e87da7f2fcf4d.tar.gz
ports-1514ae323815f626efada825028e87da7f2fcf4d.zip
Notes
Diffstat (limited to 'lang/pike76/Makefile')
-rw-r--r--lang/pike76/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/lang/pike76/Makefile b/lang/pike76/Makefile
index 37a7a52c00cd..92883b06dc4c 100644
--- a/lang/pike76/Makefile
+++ b/lang/pike76/Makefile
@@ -6,14 +6,14 @@
#
PORTNAME= pike76
-PORTVERSION= 7.6.104
+PORTVERSION= 7.6.108
CATEGORIES= lang
MASTER_SITES= ftp://pike.ida.liu.se/pub/pike/beta/${PORTVERSION}/ \
+ http://pike.ida.liu.se/pub/pike/beta/${PORTVERSION}/ \
ftp://pike.ida.liu.se/pub/pike/all/${PORTVERSION}/ \
+ http://pike.ida.liu.se/pub/pike/all/${PORTVERSION}/ \
ftp://ftp.oav.net/pike/7.6/ \
- ftp://ftp.caudium.net/pike/official_releases/${PORTVERSION}/ \
- ftp://ftp.us.caudium.net/pub/pike/7.6/ \
- ftp://ftp.us.caudium.net/pub/pike/official_releases/${PORTVERSION}/
+ ftp://ftp.caudium.net/pike/official_releases/${PORTVERSION}/
DISTNAME= Pike-v${PORTVERSION}
MAINTAINER= kiwi@oav.net
@@ -22,7 +22,6 @@ COMMENT= A dynamic programming language with a syntax similar to C++
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff \
gdbm.3:${PORTSDIR}/databases/gdbm \
- fftw.2:${PORTSDIR}/math/fftw \
pcre.0:${PORTSDIR}/devel/pcre \
nettle.2:${PORTSDIR}/security/nettle \
mird.1:${PORTSDIR}/databases/mird
@@ -38,7 +37,8 @@ OPTIONS= TTF "Add FreeType 1 support" on \
SANE "Add SANE support" off \
PDF "Add PDF support" off \
SVG2 "Add SVG2 support" off \
- TDS "Add FreeTDS (Sybase and MSSQL) support" off
+ TDS "Add FreeTDS (Sybase and MSSQL) support" off \
+ FFTW "Add libFFTW support" off
MAN1= pike.1
@@ -130,6 +130,10 @@ CONFIGURE_ARGS+= --with-ffmpeg
CONFIGURE_ARGS+= --without-ffmpeg
.endif
+.if defined(WITH_FFTW)
+LIB_DEPENDS+= fftw.2:${PORTSDIR}/math/fftw
+.endif
+
.if defined(WITH_TTF)
LIB_DEPENDS+= ttf.4:${PORTSDIR}/print/freetype
CONFIGURE_ARGS+= --with-ttflib