aboutsummaryrefslogtreecommitdiff
path: root/lang/pm3-base
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-10-16 06:15:36 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-10-16 06:15:36 +0000
commitfc665b188411fa01f878128c291693f5c4bedcd5 (patch)
tree8dcb6359b5b89d79d0a6273aea3471e74ade7aa1 /lang/pm3-base
parentf5ec868bf4b59c177c35f1cbb7837e77cbc8b58a (diff)
Notes
Diffstat (limited to 'lang/pm3-base')
-rw-r--r--lang/pm3-base/Makefile6
-rw-r--r--lang/pm3-base/files/patch-l122
-rw-r--r--lang/pm3-base/files/patch-l222
-rw-r--r--lang/pm3-base/files/patch-m3.c.diff48
4 files changed, 83 insertions, 15 deletions
diff --git a/lang/pm3-base/Makefile b/lang/pm3-base/Makefile
index 5cbcc19b18ab..48c9e54c59ba 100644
--- a/lang/pm3-base/Makefile
+++ b/lang/pm3-base/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pm3-base
PORTVERSION= 1.1.15
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR=jdp/pm3
@@ -44,10 +44,6 @@ SOVERSION= 7
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
.if ${PORTOBJFORMAT} == "aout"
TARGET= FreeBSD2
TARGETDIR= freebsd-2
diff --git a/lang/pm3-base/files/patch-l1 b/lang/pm3-base/files/patch-l1
index 7e239cb27719..91d8c9cd6ed6 100644
--- a/lang/pm3-base/files/patch-l1
+++ b/lang/pm3-base/files/patch-l1
@@ -1,5 +1,5 @@
---- libs/m3core/src/runtime/FreeBSD4/RTHeapDepC.c.orig Wed May 31 13:54:33 2000
-+++ libs/m3core/src/runtime/FreeBSD4/RTHeapDepC.c Tue Feb 18 09:33:53 2003
+--- libs/m3core/src/runtime/FreeBSD4/RTHeapDepC.c.orig Wed May 31 20:54:33 2000
++++ libs/m3core/src/runtime/FreeBSD4/RTHeapDepC.c Wed Aug 17 11:59:31 2005
@@ -98,7 +98,11 @@
#include <sys/time.h>
#include <nfs/rpcv2.h>
@@ -12,7 +12,19 @@
#include <ufs/ufs/ufsmount.h>
#endif
-@@ -693,7 +697,9 @@
+@@ -451,7 +455,11 @@
+
+ int gethostname(name, namelen) /* ok */
+ char *name;
++#if __FreeBSD__ >= 5
++size_t namelen;
++#else
+ int namelen;
++#endif
+ { int result;
+ #if __FreeBSD__ >= 2
+ int mib[2];
+@@ -693,7 +701,9 @@
void *data;
{ int result;
struct ufs_args *u_data;
@@ -22,7 +34,7 @@
struct nfs_args *n_data;
ENTER_CRITICAL;
-@@ -704,11 +710,13 @@
+@@ -704,11 +714,13 @@
MAKE_READABLE(u_data);
MAKE_READABLE(u_data->fspec);
result = syscall(SYS_mount, type, dir, flags, data);
@@ -36,7 +48,7 @@
} else if (strcmp(type, "nfs") == 0) {
n_data = (struct nfs_args*) data;
MAKE_READABLE(n_data);
-@@ -805,7 +813,11 @@
+@@ -805,7 +817,11 @@
int msgsnd(msqid, msgp, msgsz, msgflg) /* ok */
int msqid;
diff --git a/lang/pm3-base/files/patch-l2 b/lang/pm3-base/files/patch-l2
index e18ec3ae81c2..0e6e6ee56ff8 100644
--- a/lang/pm3-base/files/patch-l2
+++ b/lang/pm3-base/files/patch-l2
@@ -1,5 +1,5 @@
---- libs/m3core/src/runtime/FBSD_ALPHA/RTHeapDepC.c.orig Wed May 31 10:54:24 2000
-+++ libs/m3core/src/runtime/FBSD_ALPHA/RTHeapDepC.c Sun Apr 20 12:21:15 2003
+--- libs/m3core/src/runtime/FBSD_ALPHA/RTHeapDepC.c.orig Wed May 31 20:54:24 2000
++++ libs/m3core/src/runtime/FBSD_ALPHA/RTHeapDepC.c Wed Aug 17 12:23:04 2005
@@ -98,7 +98,11 @@
#include <sys/time.h>
#include <nfs/rpcv2.h>
@@ -12,7 +12,19 @@
#include <ufs/ufs/ufsmount.h>
#endif
-@@ -693,7 +697,9 @@
+@@ -451,7 +455,11 @@
+
+ int gethostname(name, namelen) /* ok */
+ char *name;
++#if __FreeBSD__ >= 5
++size_t namelen;
++#else
+ int namelen;
++#endif
+ { int result;
+ #if __FreeBSD__ >= 2
+ int mib[2];
+@@ -693,7 +701,9 @@
void *data;
{ int result;
struct ufs_args *u_data;
@@ -22,7 +34,7 @@
struct nfs_args *n_data;
ENTER_CRITICAL;
-@@ -704,11 +710,13 @@
+@@ -704,11 +714,13 @@
MAKE_READABLE(u_data);
MAKE_READABLE(u_data->fspec);
result = syscall(SYS_mount, type, dir, flags, data);
@@ -36,7 +48,7 @@
} else if (strcmp(type, "nfs") == 0) {
n_data = (struct nfs_args*) data;
MAKE_READABLE(n_data);
-@@ -805,7 +813,11 @@
+@@ -805,7 +817,11 @@
int msgsnd(msqid, msgp, msgsz, msgflg) /* ok */
int msqid;
diff --git a/lang/pm3-base/files/patch-m3.c.diff b/lang/pm3-base/files/patch-m3.c.diff
new file mode 100644
index 000000000000..81a26e013de6
--- /dev/null
+++ b/lang/pm3-base/files/patch-m3.c.diff
@@ -0,0 +1,48 @@
+--- language/modula3/m3compiler/m3cc/gcc/m3.c.orig Wed Aug 17 12:34:10 2005
++++ language/modula3/m3compiler/m3cc/gcc/m3.c Wed Aug 17 12:52:49 2005
+@@ -27,7 +27,7 @@
+
+
+
+-#include <varargs.h>
++#include <stdarg.h>
+ #include <stdio.h>
+ #include <errno.h>
+ #include <setjmp.h>
+@@ -991,15 +991,12 @@
+ static int current_dbg_type_count2;
+ static int current_dbg_type_count3;
+
+-static void debug_tag (kind, id, va_alist)
+- char kind;
+- char *id;
+- va_dcl
++static void debug_tag (char kind, char *id, ...)
+ {
+ va_list args;
+ char *fmt;
+
+- va_start (args);
++ va_start (args, id);
+ current_dbg_type_tag [0] = 'M';
+ current_dbg_type_tag [1] = kind;
+ current_dbg_type_tag [2] = '_';
+@@ -1031,16 +1028,14 @@
+
+ #define debug_field_id debug_field
+
+-static void debug_field_fmt (id, va_alist)
+- char *id;
+- va_dcl
++static void debug_field_fmt (char *id, ...)
+ {
+ va_list args;
+ char name [100];
+ char *fmt;
+
+ memcpy (name, id, UID_SIZE);
+- va_start (args);
++ va_start (args, id);
+ fmt = va_arg (args, char *);
+ vsprintf (name + UID_SIZE, fmt, args);
+ va_end (args);