aboutsummaryrefslogtreecommitdiff
path: root/lang/pnet-base/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-03-06 17:08:04 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-03-06 17:08:04 +0000
commitd5e5082e47bff3fff637948a78979d6a85795581 (patch)
treeca65df657f8181d835a6b8affdabe244323f89ce /lang/pnet-base/Makefile
parent9b5f0edf2756e5fa6663b6a77c6f48c57548a416 (diff)
downloadports-d5e5082e47bff3fff637948a78979d6a85795581.tar.gz
ports-d5e5082e47bff3fff637948a78979d6a85795581.zip
Notes
Diffstat (limited to 'lang/pnet-base/Makefile')
-rw-r--r--lang/pnet-base/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/lang/pnet-base/Makefile b/lang/pnet-base/Makefile
new file mode 100644
index 000000000000..b65dcbcd6bcd
--- /dev/null
+++ b/lang/pnet-base/Makefile
@@ -0,0 +1,49 @@
+# Ports collection makefile for: treecc
+# Date created: Wed Jul 11 00:45:15 EDT 2001
+# Whom: Michael Johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pnet
+PORTVERSION= ${PNET_VERSION}
+CATEGORIES= lang
+MASTER_SITES= ${PNET_MASTER_SITES}
+PKGNAMESUFFIX= base
+
+MAINTAINER= ahze@ahze.net
+COMMENT= C\# compiler and runtime engine
+
+BUILD_DEPENDS= treecc:${PORTSDIR}/lang/treecc
+LIB_DEPENDS= ffi.2:${PORTSDIR}/devel/libffi
+
+USE_LIBTOOL= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+CONFIGURE_ARGS+= --enable-threads=posix
+
+.if !defined(WITH_OPTIMIZED_CFLAGS)
+CONFIGURE_ARGS+= --disable-optimizations
+.endif
+
+INFO= pnettools
+MAN1= clrwrap.1 csant.1 cscc.1 csdoc.1 csdoc2hier.1 csdoc2html.1 \
+ csdoc2texi.1 cssrc2html.1 ilalink.1 ilasm.1 ildasm.1 ildd.1 \
+ ilfind.1 ilheader.1 ilnative.1 ilranlib.1 ilrun.1 ilsize.1 \
+ ilstrip.1 ilverify.1 resgen.1
+
+.include <bsd.port.pre.mk>
+
+post-everything::
+.if !defined(WITH_OPTIMIZED_CFLAGS)
+ @${ECHO_MSG} "Define optimized CFLAGS with"
+ @${ECHO_MSG} "WITH_OPTIMIZED_CFLAGS=yes"
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|`$$CC -print-multi-os-directory 2>/dev/null`|elf|' \
+ ${WRKSRC}/libffi/configure ${WRKSRC}/libffi/configure.in
+
+.include "${.CURDIR}/../pnet/Makefile.pnet"
+.include <bsd.port.post.mk>