aboutsummaryrefslogtreecommitdiff
path: root/lang/polyml/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2020-07-01 13:39:23 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2020-07-01 13:39:23 +0000
commit096ec9297f7fa31f10ca466c3a37d7b5a2cd73d5 (patch)
treedcb4c653e2d31d4a2bfea60b44c5462860a4695e /lang/polyml/Makefile
parentab89133de5bd5d2d3b72402ac0b307fb80781d36 (diff)
Update to 5.8
PR: 247062 Submitted by: Greg V <greg@unrelenting.technology> Approved by: Timothy Beyer <beyert@cs.ucr.edu> (maintainer)
Notes
Notes: svn path=/head/; revision=540963
Diffstat (limited to 'lang/polyml/Makefile')
-rw-r--r--lang/polyml/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/lang/polyml/Makefile b/lang/polyml/Makefile
index 41fb96ead96a..b5d4d5806a21 100644
--- a/lang/polyml/Makefile
+++ b/lang/polyml/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= polyml
-PORTVERSION= 5.7.1
+PORTVERSION= 5.8
DISTVERSIONPREFIX= v
CATEGORIES= lang
DIST_SUBDIR= ${PORTNAME}
@@ -12,11 +12,11 @@ COMMENT= Fast open-source implementation of Standard ML
LICENSE= LGPL21
-ONLY_FOR_ARCHS= amd64 i386
+ONLY_FOR_ARCHS= aarch64 amd64 i386
LIB_DEPENDS= libffi.so:devel/libffi
-USES= libtool pathfix pkgconfig
+USES= libtool localbase pathfix pkgconfig
USE_GITHUB= yes
@@ -26,11 +26,18 @@ USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
-OPTIONS_DEFINE= MOTIF
+OPTIONS_DEFINE= MOTIF GMP INTINF_AS_INT
+OPTIONS_DEFAULT=GMP INTINF_AS_INT
MOTIF_CONFIGURE_WITH= x
MOTIF_USE= motif
+GMP_CONFIGURE_WITH= gmp
+GMP_LIB_DEPENDS= libgmp.so:math/gmp
+
+INTINF_AS_INT_DESC= Use IntInf.int as int type
+INTINF_AS_INT_CONFIGURE_ENABLE= intinf-as-int
+
post-patch:
@${REINPLACE_CMD} -e 's|-lstdc++ ||' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's| modules||' ${WRKSRC}/Makefile.in