aboutsummaryrefslogtreecommitdiff
path: root/lang/polyml
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-08-15 00:42:08 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-08-15 00:42:08 +0000
commit718c5ef4c574df41050ce31a372df6bcd9ddef61 (patch)
tree563ebf11dbc8e000ae72f395dc5198fce8104e43 /lang/polyml
parente26e1fd281ecca951e642436c2f2d2cfe7489a6f (diff)
Notes
Diffstat (limited to 'lang/polyml')
-rw-r--r--lang/polyml/Makefile2
-rw-r--r--lang/polyml/distinfo6
-rw-r--r--lang/polyml/files/patch-libpolyml-sighandler.cpp15
3 files changed, 16 insertions, 7 deletions
diff --git a/lang/polyml/Makefile b/lang/polyml/Makefile
index a82dc324396f..a35e9712b249 100644
--- a/lang/polyml/Makefile
+++ b/lang/polyml/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= polyml
-PORTVERSION= 5.1
+PORTVERSION= 5.2
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/lang/polyml/distinfo b/lang/polyml/distinfo
index 3effd76a5a36..1fec9db9ca45 100644
--- a/lang/polyml/distinfo
+++ b/lang/polyml/distinfo
@@ -1,3 +1,3 @@
-MD5 (polyml/polyml.5.1.tar.gz) = c7913285e56dc06ff401a3425c57b0d4
-SHA256 (polyml/polyml.5.1.tar.gz) = bb8c0d39c1f9b8eeb880efca1c118adaa7228854f656b842f3868530e88c988b
-SIZE (polyml/polyml.5.1.tar.gz) = 4215625
+MD5 (polyml/polyml.5.2.tar.gz) = 5c0a291990f6dbce6baed857068cda06
+SHA256 (polyml/polyml.5.2.tar.gz) = bffdbe469406a746929965474fdcfff6cea1aa72e189fef1f97bfa32f862546f
+SIZE (polyml/polyml.5.2.tar.gz) = 4116253
diff --git a/lang/polyml/files/patch-libpolyml-sighandler.cpp b/lang/polyml/files/patch-libpolyml-sighandler.cpp
index 9d518640ebce..93b330966666 100644
--- a/lang/polyml/files/patch-libpolyml-sighandler.cpp
+++ b/lang/polyml/files/patch-libpolyml-sighandler.cpp
@@ -1,6 +1,6 @@
---- libpolyml/sighandler.cpp.orig 2008-04-05 16:03:20.000000000 +1100
-+++ libpolyml/sighandler.cpp 2008-04-05 16:03:29.000000000 +1100
-@@ -381,7 +381,7 @@
+--- libpolyml/sighandler.cpp.orig 2008-02-28 00:20:51.000000000 +1100
++++ libpolyml/sighandler.cpp 2008-07-27 21:26:41.000000000 +1000
+@@ -357,7 +357,7 @@
struct sigaltstack ex_stack;
#endif
memset(&ex_stack, 0, sizeof(ex_stack));
@@ -9,3 +9,12 @@
ex_stack.ss_size = SIGSTKSZ;
ex_stack.ss_flags = 0; /* not SS_DISABLE */
int sigaltstack_result = sigaltstack(&ex_stack, NULL);
+@@ -526,7 +526,7 @@
+ pthread_attr_init(&attrs);
+ pthread_attr_setdetachstate(&attrs, PTHREAD_CREATE_DETACHED);
+ #ifdef PTHREAD_STACK_MIN
+- pthread_attr_setstacksize(&attrs, PTHREAD_STACK_MIN); // Only small stack.
++ pthread_attr_setstacksize(&attrs, PTHREAD_STACK_MIN + 100); // Only small stack.
+ #endif
+ pthread_create(&detectionThreadId, &attrs, SignalDetectionThread, 0);
+ pthread_attr_destroy(&attrs);