aboutsummaryrefslogtreecommitdiff
path: root/lang/ponyc
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-01-27 14:35:19 +0000
committerSteve Wills <swills@FreeBSD.org>2019-01-27 14:35:19 +0000
commit67d5743646394aee8d2d45f638daddf7643ddf10 (patch)
tree8dfed7d4a5faf13d3815a03cb3336020a698e90f /lang/ponyc
parent22cbc19c609061d00cd224aee2519f5858937bd1 (diff)
downloadports-67d5743646394aee8d2d45f638daddf7643ddf10.tar.gz
ports-67d5743646394aee8d2d45f638daddf7643ddf10.zip
Notes
Diffstat (limited to 'lang/ponyc')
-rw-r--r--lang/ponyc/Makefile5
-rw-r--r--lang/ponyc/distinfo6
-rw-r--r--lang/ponyc/files/patch-Makefile11
-rw-r--r--lang/ponyc/files/patch-src_libponyc_codegen_genexe.c12
-rw-r--r--lang/ponyc/files/patch-src_libponyc_codegen_host.cc17
-rw-r--r--lang/ponyc/pkg-plist1
6 files changed, 6 insertions, 46 deletions
diff --git a/lang/ponyc/Makefile b/lang/ponyc/Makefile
index 87f3f5db2105..e35f22a62714 100644
--- a/lang/ponyc/Makefile
+++ b/lang/ponyc/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= ponyc
-DISTVERSION= 0.25.0
-PORTREVISION= 1
+DISTVERSION= 0.26.0
CATEGORIES= lang
MAINTAINER= greg@unrelenting.technology
@@ -54,7 +53,7 @@ PONYARCH?= core2
.endif
# keep in sync with all platforms where libunwind is available
-.if (${ARCH} == amd64 || ${ARCH} == i386)
+.if (${ARCH} == amd64 || ${ARCH} == i386 || ${ARCH} == aarch64)
LIB_DEPENDS+= libunwind.so:devel/libunwind
.endif
diff --git a/lang/ponyc/distinfo b/lang/ponyc/distinfo
index 571ca845d1cf..2d84b4270c57 100644
--- a/lang/ponyc/distinfo
+++ b/lang/ponyc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1539770206
-SHA256 (ponylang-ponyc-0.25.0_GH0.tar.gz) = 8420d84f178db325934d77dc407a7f98d6bd14b8cf8036e17b41f886f5820cb2
-SIZE (ponylang-ponyc-0.25.0_GH0.tar.gz) = 1378042
+TIMESTAMP = 1548588554
+SHA256 (ponylang-ponyc-0.26.0_GH0.tar.gz) = e65631dbf5418abd465cbd5912794feb61c0db9b76b916b39772ad2f623ad16e
+SIZE (ponylang-ponyc-0.26.0_GH0.tar.gz) = 1391987
diff --git a/lang/ponyc/files/patch-Makefile b/lang/ponyc/files/patch-Makefile
deleted file mode 100644
index e1d6e8d5e811..000000000000
--- a/lang/ponyc/files/patch-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig 2018-10-17 10:11:59 UTC
-+++ Makefile
-@@ -806,7 +806,7 @@ $($(1))/libponyrt.$(LIB_EXT): $(depends) $(ofiles)
- $(SILENT)rm -f $(PONY_BUILD_DIR)/dtrace_probes.o
- $(SILENT)$(DTRACE) -G -s $(PONY_SOURCE_DIR)/common/dtrace_probes.d -o $(PONY_BUILD_DIR)/dtrace_probes.o $(ofiles)
- $(SILENT)$(AR) $(AR_FLAGS) $$@ $(ofiles) $(PONY_BUILD_DIR)/dtrace_probes.o
-- $(SILENT)$(AR) $(AR_FLAGS) $(PONY_BUILD_DIR)/libdtrace_probes.a $(PONY_BUILD_DIR)/dtrace_probes.o
-+ $(SILENT)$(AR) $(AR_FLAGS) $(lib)/libdtrace_probes.a $(PONY_BUILD_DIR)/dtrace_probes.o
- else
- $(SILENT)$(AR) $(AR_FLAGS) $$@ $(ofiles)
- endif
diff --git a/lang/ponyc/files/patch-src_libponyc_codegen_genexe.c b/lang/ponyc/files/patch-src_libponyc_codegen_genexe.c
deleted file mode 100644
index 2dd9266dbac8..000000000000
--- a/lang/ponyc/files/patch-src_libponyc_codegen_genexe.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/libponyc/codegen/genexe.c.orig 2018-10-13 12:30:06 UTC
-+++ src/libponyc/codegen/genexe.c
-@@ -347,8 +347,7 @@ static bool link_exe(compile_t* c, ast_t* program,
- "";
- #endif
- const char* lexecinfo =
--#if (defined(PLATFORM_IS_LINUX) && !defined(__GLIBC__)) || \
-- (defined(PLATFORM_IS_BSD) && defined(DEBUG))
-+#if (defined(PLATFORM_IS_LINUX) && !defined(__GLIBC__)) || defined(PLATFORM_IS_BSD)
- "-lexecinfo";
- #else
- "";
diff --git a/lang/ponyc/files/patch-src_libponyc_codegen_host.cc b/lang/ponyc/files/patch-src_libponyc_codegen_host.cc
deleted file mode 100644
index 7a34e833a61a..000000000000
--- a/lang/ponyc/files/patch-src_libponyc_codegen_host.cc
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/libponyc/codegen/host.cc.orig 2018-10-17 11:42:19 UTC
-+++ src/libponyc/codegen/host.cc
-@@ -56,7 +56,14 @@ char* LLVMGetHostCPUFeatures()
- {
- StringMap<bool> features;
- bool got_features = sys::getHostCPUFeatures(features);
-+#ifdef PLATFORM_IS_ARM
-+ // LLVM might not have CPU features support on e.g. FreeBSD/aarch64
-+ if (!got_features) {
-+ features["neon"] = true;
-+ }
-+#else
- pony_assert(got_features);
-+#endif
- (void)got_features;
-
- // Calculate the size of buffer that will be needed to return all features.
diff --git a/lang/ponyc/pkg-plist b/lang/ponyc/pkg-plist
index 5cce42657fed..3d2fd9b80006 100644
--- a/lang/ponyc/pkg-plist
+++ b/lang/ponyc/pkg-plist
@@ -62,6 +62,7 @@ lib/pony/%%VERSION%%/packages/cli/env_vars.pony
lib/pony/%%VERSION%%/packages/collections/_test.pony
lib/pony/%%VERSION%%/packages/collections/flag.pony
lib/pony/%%VERSION%%/packages/collections/hashable.pony
+lib/pony/%%VERSION%%/packages/collections/heap.pony
lib/pony/%%VERSION%%/packages/collections/list.pony
lib/pony/%%VERSION%%/packages/collections/list_node.pony
lib/pony/%%VERSION%%/packages/collections/map.pony