aboutsummaryrefslogtreecommitdiff
path: root/lang/pure
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2011-04-09 19:21:47 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2011-04-09 19:21:47 +0000
commitaf5336d5861ff946dfcbbe57394c717baea31683 (patch)
tree5816a639a1c544d6bc6070ddb5d97746735d1b92 /lang/pure
parent91d715f0853f9198b903153294f211522c32ff3d (diff)
downloadports-af5336d5861ff946dfcbbe57394c717baea31683.tar.gz
ports-af5336d5861ff946dfcbbe57394c717baea31683.zip
Notes
Diffstat (limited to 'lang/pure')
-rw-r--r--lang/pure/Makefile18
-rw-r--r--lang/pure/distinfo8
-rw-r--r--lang/pure/files/patch-interpreter.cc32
-rw-r--r--lang/pure/pkg-plist9
4 files changed, 25 insertions, 42 deletions
diff --git a/lang/pure/Makefile b/lang/pure/Makefile
index be859c280642..7575a5d99cec 100644
--- a/lang/pure/Makefile
+++ b/lang/pure/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pure
-PORTVERSION= 0.46
+PORTVERSION= 0.47
CATEGORIES= lang
MASTER_SITES= http://pure-lang.googlecode.com/files/
DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz ${PORTNAME}-docs-${PORTVERSION}.tar.gz
@@ -23,15 +23,27 @@ LICENSE= LGPL3
SUB_FILES= pkg-message
USE_GCC= 4.2+
-USE_AUTOTOOLS= libtool
+USE_AUTOTOOLS= libltdl
GNU_CONFIGURE= yes
USE_GMAKE= yes
+USE_GNOME= gnomehack
MAKE_JOBS_SAFE= yes
CONFIGURE_ARGS= --with-libgmp-prefix=${LOCALBASE} --enable-release
+OPTIONS= EMACS "Compile pure-mode.el with Emacs" off
+
.include <bsd.port.options.mk>
+.if defined(WITH_EMACS)
+USE_EMACS= yes
+MAKE_ARGS+= emacs_prefix=${PREFIX}
+PLIST_SUB+= ELC=""
+.else
+CONFIGURE_ARGS+= --without-elisp
+PLIST_SUB+= ELC="@comment "
+.endif
+
.if ${ARCH} == "amd64"
CONFIGURE_TARGET= x86_64-portbld-freebsd
.endif
@@ -57,7 +69,7 @@ PLIST_SUB+= DOCS="@comment "
post-install:
.if !defined(NOPORTDATA)
@${MKDIR} ${DATADIR}/etc/
- (cd ${WRKSRC} && ${COPYTREE_SHARE} etc/ ${DATADIR}/)
+ (cd ${WRKSRC} && ${RM} -f etc/*.in && ${COPYTREE_SHARE} etc/ ${DATADIR}/)
.endif
.if !defined(NOPORTEXAMPLES)
diff --git a/lang/pure/distinfo b/lang/pure/distinfo
index 73cf0f8dda3c..fcd05f6c3461 100644
--- a/lang/pure/distinfo
+++ b/lang/pure/distinfo
@@ -1,4 +1,4 @@
-SHA256 (pure-0.46.tar.gz) = 172cd3196d5c44341ec4cfaff801b0350d36bb7f92b7fa93d361bedd34f83896
-SIZE (pure-0.46.tar.gz) = 900928
-SHA256 (pure-docs-0.46.tar.gz) = 3429e14445bfb05a3618c2bb7800a695d08aea347d9e6c3b908fe702b5ef0803
-SIZE (pure-docs-0.46.tar.gz) = 2560377
+SHA256 (pure-0.47.tar.gz) = 7b3d0093fd695178e154cd24a4983dbff479a62ef840c11ca94af0998699409a
+SIZE (pure-0.47.tar.gz) = 1028429
+SHA256 (pure-docs-0.47.tar.gz) = 5d26edc1dce5151a616ad11378657fbf792edf2ddefa31c70934e6d3c011258c
+SIZE (pure-docs-0.47.tar.gz) = 2817481
diff --git a/lang/pure/files/patch-interpreter.cc b/lang/pure/files/patch-interpreter.cc
deleted file mode 100644
index 44d1716aa277..000000000000
--- a/lang/pure/files/patch-interpreter.cc
+++ /dev/null
@@ -1,32 +0,0 @@
---- interpreter.cc.orig 2010-11-08 02:57:58.000000000 -0600
-+++ interpreter.cc 2011-03-19 02:01:57.145664585 -0500
-@@ -6709,6 +6709,11 @@ int interpreter::compiler(string out, li
- // Compile and link, if requested.
- if (target != out) {
- assert(bc_target);
-+ string cc = "gcc";
-+ string cxx = "g++";
-+ const char *env;
-+ if (env = getenv("CC")) cc = env;
-+ if (env = getenv("CXX")) cxx = env;
- bool vflag = (verbose&verbosity::compiler) != 0;
- string libs;
- set<string> libset;
-@@ -6735,7 +6740,7 @@ int interpreter::compiler(string out, li
- if (WIFEXITED(status) && WEXITSTATUS(status) == 0 && ext!=".s") {
- // Assemble.
- string obj = (ext==".o")?out:out+".o";
-- cmd = "gcc -c "+quote(asmfile)+" -o "+quote(obj);
-+ cmd = cc+" -c "+quote(asmfile)+" -o "+quote(obj);
- if (vflag) std::cerr << cmd << '\n';
- status = system(cmd.c_str());
- unlink(asmfile.c_str());
-@@ -6755,7 +6760,7 @@ int interpreter::compiler(string out, li
- " -lpure";
- if (ext != ".o") {
- // Link.
-- cmd = "g++ -o "+quote(out)+" "+quote(libdir)+"pure_main.o "+linkopts;
-+ cmd = cxx+" -o "+quote(out)+" "+quote(libdir)+"pure_main.o "+linkopts;
- if (vflag) std::cerr << cmd << '\n';
- status = system(cmd.c_str());
- unlink(obj.c_str());
diff --git a/lang/pure/pkg-plist b/lang/pure/pkg-plist
index 393c6ab0c503..27bd08e9f01d 100644
--- a/lang/pure/pkg-plist
+++ b/lang/pure/pkg-plist
@@ -1,8 +1,8 @@
bin/pure
include/pure/runtime.h
lib/libpure.so
-lib/libpure.so.6
-lib/libpure.so.6.0
+lib/libpure.so.7
+lib/libpure.so.7.0
lib/pure/array.pure
lib/pure/avltrees.pure
lib/pure/dict.pure
@@ -17,11 +17,14 @@ lib/pure/primitives.pure
lib/pure/pure_main.c
lib/pure/pure_main.o
lib/pure/quasiquote.pure
-lib/pure/quasiquote2.pure
+lib/pure/quasiquote1.pure
lib/pure/records.pure
lib/pure/set.pure
lib/pure/strings.pure
lib/pure/system.pure
+libdata/pkgconfig/pure.pc
+%%ELC%%%%EMACS_SITE_LISPDIR%%/pure-mode.el
+%%ELC%%%%EMACS_SITE_LISPDIR%%/pure-mode.elc
%%DOCS%%lib/pure/docs
@dirrm lib/pure
@dirrm include/pure