aboutsummaryrefslogtreecommitdiff
path: root/lang/pure
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-09 13:43:59 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-09 13:43:59 +0000
commita851269bfa4538b5ba537c3f91e9eca1a5553fc6 (patch)
treeb1316d4b675a195bc9d53570fd5313512162f3f1 /lang/pure
parenta61d65d14b0d89ac4d89a8b6252f1e63b3f339ae (diff)
downloadports-a851269bfa4538b5ba537c3f91e9eca1a5553fc6.tar.gz
ports-a851269bfa4538b5ba537c3f91e9eca1a5553fc6.zip
Notes
Diffstat (limited to 'lang/pure')
-rw-r--r--lang/pure/Makefile38
-rw-r--r--lang/pure/bsd.pure.mk2
2 files changed, 19 insertions, 21 deletions
diff --git a/lang/pure/Makefile b/lang/pure/Makefile
index cf7a7eb49743..794962932a6d 100644
--- a/lang/pure/Makefile
+++ b/lang/pure/Makefile
@@ -4,36 +4,35 @@
PORTNAME= pure
PORTVERSION= 0.55
CATEGORIES= lang
-DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz ${PORTNAME}-docs-${PORTVERSION}.tar.gz
+DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz \
+ ${PORTNAME}-docs-${PORTVERSION}.tar.gz
MAINTAINER= lichray@gmail.com
-COMMENT= A modern-style functional programming language
+COMMENT= Modern-style functional programming language
LICENSE= GPLv3 LGPL3
LICENSE_COMB= dual
-LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp \
- mpfr:${PORTSDIR}/math/mpfr
+LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp \
+ libmpfr.so:${PORTSDIR}/math/mpfr
BUILD_DEPENDS= llvm31>=3.1:${PORTSDIR}/devel/llvm31
RUN_DEPENDS= llvm31>=3.1:${PORTSDIR}/devel/llvm31
-MAN1= pure.1
-SUB_FILES= pkg-message
-
-USES= iconv
+USES= iconv pkgconfig
USE_AUTOTOOLS= libltdl
GNU_CONFIGURE= yes
-USE_GNOME= gnomehack pkgconfig
-USE_PURE= yes
+USE_GNOME= gnomehack
USE_LDCONFIG= yes
-MAKE_JOBS_SAFE= yes
+USE_PURE= yes
CONFIGURE_ARGS= --with-libgmp-prefix=${LOCALBASE} --enable-release
OPTIONS_DEFINE= EMACS
-
EMACS_DESC= Compile pure-mode.el with Emacs
+MAN1= pure.1
+SUB_FILES= pkg-message
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MEMACS}
@@ -77,26 +76,25 @@ SUB_LIST+= NOCLANG="@comment "
.endif
.include "${.CURDIR}/bsd.pure.mk"
-
.include <bsd.port.pre.mk>
post-install:
.if !defined(NOPORTDATA)
- @${MKDIR} ${DATADIR}/etc/
- (cd ${WRKSRC} && ${RM} -f etc/*.in && ${COPYTREE_SHARE} etc/ ${DATADIR}/)
+ @${MKDIR} ${DATADIR}/etc
+ (cd ${WRKSRC} && ${RM} -f etc/*.in && ${COPYTREE_SHARE} etc ${DATADIR})
.endif
-
.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
- (cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
+ (cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
.endif
-
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- (cd ${WRKDIR}/${PORTNAME}-docs-${PORTVERSION} && ${RM} -f Makefile && ${COPYTREE_SHARE} \* ${DOCSDIR})
+ (cd ${WRKDIR}/${PORTNAME}-docs-${PORTVERSION} && \
+ ${RM} -f Makefile && ${COPYTREE_SHARE} . ${DOCSDIR})
${LN} -fs ${DOCSDIR} ${PREFIX}/lib/${PORTNAME}/docs
.endif
-
+ @${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
.include <bsd.port.post.mk>
diff --git a/lang/pure/bsd.pure.mk b/lang/pure/bsd.pure.mk
index 4d3758e026e6..c05529e1c0c6 100644
--- a/lang/pure/bsd.pure.mk
+++ b/lang/pure/bsd.pure.mk
@@ -46,7 +46,7 @@ CATEGORIES= _PURE_${PORTNAME}_cat
.if ${PORTNAME} != pure
.if ${USE_PURE} == yes
-LIB_DEPENDS+= pure.8:${PORTSDIR}/lang/pure
+LIB_DEPENDS+= libpure.so.8:${PORTSDIR}/lang/pure
.else
. for dep in ${USE_PURE}
_PURE_LIBDIR= ${LOCALBASE}/lib/pure