aboutsummaryrefslogtreecommitdiff
path: root/lang/pure
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-04-09 14:05:20 +0000
committerJohn Marino <marino@FreeBSD.org>2015-04-09 14:05:20 +0000
commit931d8515a555b930ab8d4cea7559000ad8c4b599 (patch)
tree5265a581108b7b304643ec36632f41ebae5a031b /lang/pure
parentae0ab8a5eea28e9d5ea35b6dd8e795ff76b66447 (diff)
lang/pure: Unbreak. Version 0.58 was always llvm 3.3 compatible
This port was marked for removal based on the information that pure required llvm 3.2. Pure apparently is continuously developed. - Version 0.58 - (this one) compatible with llvm 3.3 - Version 0.59 - compatible with llvm 3.4 - Version 0.61 - compatible with llvm 3.5 - Version 0.64 - latest I didn't reset the maintainer, but it's suspicious that it was marked broken this long for no good reason and no heads up from maintainer. While here, unmask install commands, wrap lines, be DF friendly. Approved by: blanket.
Notes
Notes: svn path=/head/; revision=383643
Diffstat (limited to 'lang/pure')
-rw-r--r--lang/pure/Makefile24
1 files changed, 11 insertions, 13 deletions
diff --git a/lang/pure/Makefile b/lang/pure/Makefile
index 446a8c076093..6e17f0bb92c2 100644
--- a/lang/pure/Makefile
+++ b/lang/pure/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pure
PORTVERSION= 0.58
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= https://cdn.bitbucket.org/purelang/pure-lang/downloads/
DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz ${PORTNAME}-docs-${PORTVERSION}.tar.gz
@@ -15,16 +15,12 @@ COMMENT= Modern-style functional programming language
LICENSE= GPLv3 LGPL3
LICENSE_COMB= dual
-LLVM_VERSION= 32
-
-BROKEN= Depends on deleted devel/llvm32
-DEPRECATED= Old revision of software, depends on deleted version of llvm
-EXPIRATION_DATE= 2015-05-14
+LLVM_VERSION= 33
LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl \
libgmp.so:${PORTSDIR}/math/gmp \
libmpfr.so:${PORTSDIR}/math/mpfr
-#BUILD_DEPENDS= llvm-config${LLVM_VERSION}:${PORTSDIR}/devel/llvm${LLVM_VERSION}
+BUILD_DEPENDS= llvm-config${LLVM_VERSION}:${PORTSDIR}/devel/llvm${LLVM_VERSION}
RUN_DEPENDS:= ${BUILD_DEPENDS}
SUB_FILES= pkg-message
@@ -73,25 +69,27 @@ SUB_LIST+= NOCLANG="@comment "
CONFIGURE_ARGS+= --without-readline
.endif
-.if ${ARCH} == "amd64"
-CONFIGURE_TARGET= x86_64-portbld-freebsd
-.endif
+CONFIGURE_TARGET= ${ARCH:S/amd64/x86_64/}-portbld-${OPSYS:tl}
post-install:
.if ${PORT_OPTIONS:METC}
@${MKDIR} ${STAGEDIR}${DATADIR}/etc/
- @(cd ${WRKSRC} && ${RM} -f etc/*.in && ${COPYTREE_SHARE} etc/ ${STAGEDIR}${DATADIR})
+ (cd ${WRKSRC} && ${RM} -f etc/*.in && \
+ ${COPYTREE_SHARE} etc/ ${STAGEDIR}${DATADIR})
.endif
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- @(cd ${WRKDIR}/${PORTNAME}-docs-${PORTVERSION} && ${RM} -f Makefile && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
+ (cd ${WRKDIR}/${PORTNAME}-docs-${PORTVERSION} && \
+ ${RM} -f Makefile && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
${LN} -sf ${DOCSDIR} ${STAGEDIR}${PREFIX}/lib/${PORTNAME}/docs
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
+ (cd ${WRKSRC}/examples && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
.endif
.include <bsd.port.mk>