aboutsummaryrefslogtreecommitdiff
path: root/lang/pure
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2012-06-06 22:04:55 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2012-06-06 22:04:55 +0000
commit9f0134c61e41e5ee40c8c95b584ea099883e9324 (patch)
treea6c6faa84cc70f7429a37d813aa34f586c39ecdc /lang/pure
parentb1498182fb6bd89181955abc4078d6d87b4062a9 (diff)
downloadports-9f0134c61e41e5ee40c8c95b584ea099883e9324.tar.gz
ports-9f0134c61e41e5ee40c8c95b584ea099883e9324.zip
Notes
Diffstat (limited to 'lang/pure')
-rw-r--r--lang/pure/Makefile21
-rw-r--r--lang/pure/distinfo8
-rw-r--r--lang/pure/files/pkg-message.in18
3 files changed, 27 insertions, 20 deletions
diff --git a/lang/pure/Makefile b/lang/pure/Makefile
index 1497782144f3..c29907da38f8 100644
--- a/lang/pure/Makefile
+++ b/lang/pure/Makefile
@@ -6,17 +6,18 @@
#
PORTNAME= pure
-PORTVERSION= 0.54
+PORTVERSION= 0.55
CATEGORIES= lang
DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz ${PORTNAME}-docs-${PORTVERSION}.tar.gz
MAINTAINER= lichray@gmail.com
COMMENT= A modern-style functional programming language
-LICENSE= LGPL3
+LICENSE= GPLv3 LGPL3
+LICENSE_COMB= dual
-LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
- mpfr.4:${PORTSDIR}/math/mpfr
+LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp \
+ mpfr:${PORTSDIR}/math/mpfr
BUILD_DEPENDS= llvm>=2.9:${PORTSDIR}/devel/llvm
RUN_DEPENDS= llvm>=2.9:${PORTSDIR}/devel/llvm
@@ -32,11 +33,13 @@ MAKE_JOBS_SAFE= yes
CONFIGURE_ARGS= --with-libgmp-prefix=${LOCALBASE} --enable-release
-OPTIONS= EMACS "Compile pure-mode.el with Emacs" off
+OPTIONS_DEFINE= EMACS
+
+EMACS_DESC= "Compile pure-mode.el with Emacs"
.include <bsd.port.options.mk>
-.if defined(WITH_EMACS)
+.if ${PORT_OPTIONS:MEMACS}
USE_EMACS= yes
MAKE_ARGS+= emacs_prefix=${PREFIX}
PLIST_SUB+= ELC=""
@@ -70,6 +73,12 @@ PLIST_SUB+= DOCS=""
PLIST_SUB+= DOCS="@comment "
.endif
+.if ${OSVERSION} < 900014
+SUB_LIST+= NOCLANG=""
+.else
+SUB_LIST+= NOCLANG="@comment "
+.endif
+
.include <bsd.port.pre.mk>
post-install:
diff --git a/lang/pure/distinfo b/lang/pure/distinfo
index a5ac4e7c175a..4be487e1889b 100644
--- a/lang/pure/distinfo
+++ b/lang/pure/distinfo
@@ -1,4 +1,4 @@
-SHA256 (pure/pure-0.54.tar.gz) = ca09b655e09312912fb626d00b828d713fdccbb12caf532512330bbf643efb7e
-SIZE (pure/pure-0.54.tar.gz) = 1135611
-SHA256 (pure/pure-docs-0.54.tar.gz) = 1d1d52fbe8b5c7fb1ec26b6afef003884640b0d9c71eb4f0cafe0875a0ca19ef
-SIZE (pure/pure-docs-0.54.tar.gz) = 3535023
+SHA256 (pure/pure-0.55.tar.gz) = 36dbf1b77719a8031766b30812ac89102188d01ae9da80c2b53889f501cb58a7
+SIZE (pure/pure-0.55.tar.gz) = 1147787
+SHA256 (pure/pure-docs-0.55.tar.gz) = 2cd0045c8fd126cf41cb847f2842e11b7c0480c8cb8d5ea33470cf7edcfd1db9
+SIZE (pure/pure-docs-0.55.tar.gz) = 3540249
diff --git a/lang/pure/files/pkg-message.in b/lang/pure/files/pkg-message.in
index 9f4e0365a099..dfa1aa19c52a 100644
--- a/lang/pure/files/pkg-message.in
+++ b/lang/pure/files/pkg-message.in
@@ -4,17 +4,15 @@
%%ETC%%
A text-based browser, such as one of following
-lynx www/lynx
-w3m www/w3m
+ lynx: www/lynx
+ w3a: mwww/w3m
is recommended to use the `help' command inside the
interpreter. Check pure(1) for details.
-
-To enable the inline C/C++ code compilation, one of
-following is required:
-
-clang lang/clang
-llvm-gcc4 lang/llvm-gcc4
-
-Install them as needed.
+%%NOCLANG%%
+%%NOCLANG%%To enable the inline C/C++ code compilation,
+%%NOCLANG%%
+%%NOCLANG%% clang: lang/clang
+%%NOCLANG%%
+%%NOCLANG%%is required.
====