aboutsummaryrefslogtreecommitdiff
path: root/lang/pure
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-09-30 22:39:50 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-09-30 22:39:50 +0000
commite380f6b979530ad9a7d8528a85e8ebf5597ff215 (patch)
treea1573f4f920843203a9e62840d28c632e2c2989a /lang/pure
parent83cda161395179c476ec6c0cb80fcfedec25af08 (diff)
downloadports-e380f6b979530ad9a7d8528a85e8ebf5597ff215.tar.gz
ports-e380f6b979530ad9a7d8528a85e8ebf5597ff215.zip
Notes
Diffstat (limited to 'lang/pure')
-rw-r--r--lang/pure/bsd.pure.mk96
1 files changed, 0 insertions, 96 deletions
diff --git a/lang/pure/bsd.pure.mk b/lang/pure/bsd.pure.mk
deleted file mode 100644
index 7aa4cdec3dc6..000000000000
--- a/lang/pure/bsd.pure.mk
+++ /dev/null
@@ -1,96 +0,0 @@
-# ex:ts=8
-#
-# $FreeBSD$
-#
-# bsd.pure.mk - Support for the Pure language packages
-#
-# Author: Zhihao Yuan <lichray@gmail.com>
-#
-# USE_PURE - Set it to 'yes' to use libpure.so.
-# Others are regarded as a list of *RUN_DEPENDS*
-# to pure-* addons. For example,
-# USE_PURE= ffi makes the port depends on pure-ffi at runtime.
-# USE_PURE_BUILD - Set it to 'yes' to change the addons in USE_PURE
-# list to *BUILD_DEPENDS*.
-# NO_PURE_EXAMPLES - Don't automatically install examples/.
-
-.if !defined(PURE_include)
-
-PURE_MAINTAINER=lichray@gmail.com
-PURE_include= bsd.pure.mk
-
-MASTER_SITES?= http://pure-lang.googlecode.com/files/
-DIST_SUBDIR= pure
-
-USES+= gmake
-
-_PURE_audio_cat= audio
-_PURE_csv_cat= textproc
-_PURE_ffi_cat= devel
-_PURE_gen_cat= devel
-_PURE_gen_util= pure-gen
-_PURE_gl_cat= graphics
-_PURE_gl_fn= GL
-_PURE_gtk_cat= x11-toolkits
-_PURE_mpfr_cat= math
-_PURE_readline_cat= devel
-_PURE_sockets_cat= net
-_PURE_sql3_cat= databases
-_PURE_tk_cat= x11-toolkits
-_PURE_xml_cat= textproc
-
-.ifdef _PURE_${PORTNAME}_cat
-CATEGORIES= _PURE_${PORTNAME}_cat
-.endif
-
-.if ${PORTNAME} != pure
-
-.if ${USE_PURE} == yes
-LIB_DEPENDS+= libpure.so.8:${PORTSDIR}/lang/pure
-.else
-. for dep in ${USE_PURE}
-_PURE_LIBDIR= ${LOCALBASE}/lib/pure
-_PURE_PORTDIR= ${PORTSDIR}/${_PURE_${dep}_cat}/pure-${dep}
-. ifdef _PURE_${dep}_cat
-. ifdef _PURE_${dep}_util
-BUILD_DEPENDS+= ${_PURE_${dep}_util}:${_PURE_PORTDIR}
-. else
-. ifdef USE_PURE_BUILD
-. ifdef _PURE_${dep}_fn
-BUILD_DEPENDS+= ${_PURE_LIBDIR}/${_PURE_${dep}_fn}.pure:${_PURE_PORTDIR}
-. else
-BUILD_DEPENDS+= ${_PURE_LIBDIR}/${dep}.pure:${_PURE_PORTDIR}
-. endif
-. endif
-. ifdef _PURE_${dep}_fn
-RUN_DEPENDS+= ${_PURE_LIBDIR}/${_PURE_${dep}_fn}.pure:${_PURE_PORTDIR}
-. else
-RUN_DEPENDS+= ${_PURE_LIBDIR}/${dep}.pure:${_PURE_PORTDIR}
-. endif
-. endif
-. else
-. error pure-${dep} is not supported by "bsd.pure.mk"
-. endif
-. endfor
-.endif
-
-.endif # PORTNAME != pure
-
-MAKE_ARGS+= prefix=${PREFIX} mandir=${PREFIX}/man \
- CC=${CC} CFLAGS="${CFLAGS}" \
- CXX=${CXX} CXXFLAGS="${CXXFLAGS}" \
- CPPFLAGS+=-I${LOCALBASE}/include \
- LDFLAGS+=-L${LOCALBASE}/lib
-
-.if ${PORTNAME:Mpure-*} !="" && !defined(NO_PURE_EXAMPLES)
-PORTEXAMPLES= *
-
-post-install:
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- (cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
-.endif
-
-.endif
-
-.endif #!defined(PURE_include)