aboutsummaryrefslogtreecommitdiff
path: root/lang/py-compiler
diff options
context:
space:
mode:
authorJohann Visagie <wjv@FreeBSD.org>2002-04-23 14:35:59 +0000
committerJohann Visagie <wjv@FreeBSD.org>2002-04-23 14:35:59 +0000
commit3dcf8856c911c509ffbe9c2dc13177fb13763644 (patch)
treeda5634ba3667a3a1d4129613f0d4ef0fe97b7fbd /lang/py-compiler
parent77b84a6a9137d7feed0722b519223687a7574d4a (diff)
Notes
Diffstat (limited to 'lang/py-compiler')
-rw-r--r--lang/py-compiler/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/lang/py-compiler/Makefile b/lang/py-compiler/Makefile
index 98ceefa97d4c..8331614f4e43 100644
--- a/lang/py-compiler/Makefile
+++ b/lang/py-compiler/Makefile
@@ -23,6 +23,11 @@ DIST_SUBDIR= python
USE_PYTHON= yes
WRKSRC= ${PYTHON_WRKSRC}/Tools/${PORTNAME}
+.include <bsd.port.pre.mk>
+.if ${PYTHON_REL} >= 220
+FORBIDDEN= "Part of the standard library from Python 2.2 upwards"
+.endif
+
do-build:
@ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py build
@@ -30,4 +35,4 @@ do-install:
@ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} \
setup.py install -c -O1 --prefix=${PREFIX}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>