aboutsummaryrefslogtreecommitdiff
path: root/lang/py-compiler
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-01-08 10:19:39 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-01-08 10:19:39 +0000
commite26574611bb71f40eb49d3ed74c77b725d64f269 (patch)
tree0354f8adc410925288f471012eb5cddda22f8160 /lang/py-compiler
parentac56f89d8248193695d06edaccb27ea77e1c2dd1 (diff)
downloadports-e26574611bb71f40eb49d3ed74c77b725d64f269.tar.gz
ports-e26574611bb71f40eb49d3ed74c77b725d64f269.zip
Notes
Diffstat (limited to 'lang/py-compiler')
-rw-r--r--lang/py-compiler/Makefile31
-rw-r--r--lang/py-compiler/distinfo3
-rw-r--r--lang/py-compiler/files/setup.py29
-rw-r--r--lang/py-compiler/pkg-descr8
-rw-r--r--lang/py-compiler/pkg-plist34
5 files changed, 0 insertions, 105 deletions
diff --git a/lang/py-compiler/Makefile b/lang/py-compiler/Makefile
deleted file mode 100644
index 14a852be46e9..000000000000
--- a/lang/py-compiler/Makefile
+++ /dev/null
@@ -1,31 +0,0 @@
-# New ports collection makefile for: py-compiler
-# Date created: 6 September 2001
-# Whom: Johann Visagie <wjv@FreeBSD.org>
-#
-# $FreeBSD$
-#
-# XXX The compiler package is included in Python 2.1 upwards.
-# This port somehow needs to take this into account.
-
-PORTNAME= compiler
-PORTVERSION= ${PYTHON_PORTVERSION}
-CATEGORIES= lang python
-MASTER_SITES= http://www.python.org/ftp/python/${PORTVERSION}/ \
- http://SunSITE.Informatik.RWTH-Aachen.DE/python/ftp/python/${PORTVERSION}/
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTFILES= ${PYTHON_DISTFILE}
-
-MAINTAINER= pgollucci@FreeBSD.org
-COMMENT= A Python source to bytecode compiler
-
-DIST_SUBDIR= python
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-WRKSRC= ${PYTHON_WRKSRC}/Tools/${PORTNAME}
-
-.include <bsd.port.pre.mk>
-.if ${PYTHON_REL} >= 220
-IGNORE= is part of the standard library from Python 2.2 upwards
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/lang/py-compiler/distinfo b/lang/py-compiler/distinfo
deleted file mode 100644
index 9a63d62ef45b..000000000000
--- a/lang/py-compiler/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (python/Python-2.5.1.tgz) = cca695828df8adc3e69b637af07522e1
-SHA256 (python/Python-2.5.1.tgz) = 1f5caee846049ca30d996f9403eefdb996295c4af664867e35dcc5eb36e4e7e8
-SIZE (python/Python-2.5.1.tgz) = 11060830
diff --git a/lang/py-compiler/files/setup.py b/lang/py-compiler/files/setup.py
deleted file mode 100644
index 402918ee225c..000000000000
--- a/lang/py-compiler/files/setup.py
+++ /dev/null
@@ -1,29 +0,0 @@
-#!/usr/bin/env python
-# To use:
-# python setup.py install
-#
-
-__version__ = "$FreeBSD: /tmp/pcvs/ports/lang/py-compiler/files/Attic/setup.py,v 1.1 2001-09-06 14:15:37 wjv Exp $"
-
-try:
- import distutils
- from distutils import sysconfig
- from distutils.command.install import install
- from distutils.core import setup, Extension
-except:
- raise SystemExit, "Distutils problem"
-
-prefix = sysconfig.PREFIX
-inc_dirs = [prefix + "/include"]
-lib_dirs = [prefix + "/lib"]
-libs = ["expat"]
-
-setup(name = "pyexpat",
- description = "Interface to the Expat XML parser",
-
- ext_modules = [Extension("pyexpat", ["pyexpat.c"],
- include_dirs = inc_dirs,
- define_macros = [("HAVE_EXPAT_H", 1)],
- libraries = libs,
- library_dirs = lib_dirs)]
- )
diff --git a/lang/py-compiler/pkg-descr b/lang/py-compiler/pkg-descr
deleted file mode 100644
index 372fe29dbd12..000000000000
--- a/lang/py-compiler/pkg-descr
+++ /dev/null
@@ -1,8 +0,0 @@
-A Python source to bytecode compiler written in Python, including an
-interface for manipulating abstract syntax trees.
-
-Still under development.
-
-Author: Jeremy Hylton <jeremy@beopen.com>
-
--- Johann Visagie <wjv@FreeBSD.org>
diff --git a/lang/py-compiler/pkg-plist b/lang/py-compiler/pkg-plist
deleted file mode 100644
index 1926f48368b6..000000000000
--- a/lang/py-compiler/pkg-plist
+++ /dev/null
@@ -1,34 +0,0 @@
-lib/%%PYTHON_VERSION%%/site-packages/compiler/__init__.py
-lib/%%PYTHON_VERSION%%/site-packages/compiler/__init__.pyc
-lib/%%PYTHON_VERSION%%/site-packages/compiler/__init__.pyo
-lib/%%PYTHON_VERSION%%/site-packages/compiler/ast.py
-lib/%%PYTHON_VERSION%%/site-packages/compiler/ast.pyc
-lib/%%PYTHON_VERSION%%/site-packages/compiler/ast.pyo
-lib/%%PYTHON_VERSION%%/site-packages/compiler/astgen.py
-lib/%%PYTHON_VERSION%%/site-packages/compiler/astgen.pyc
-lib/%%PYTHON_VERSION%%/site-packages/compiler/astgen.pyo
-lib/%%PYTHON_VERSION%%/site-packages/compiler/consts.py
-lib/%%PYTHON_VERSION%%/site-packages/compiler/consts.pyc
-lib/%%PYTHON_VERSION%%/site-packages/compiler/consts.pyo
-lib/%%PYTHON_VERSION%%/site-packages/compiler/future.py
-lib/%%PYTHON_VERSION%%/site-packages/compiler/future.pyc
-lib/%%PYTHON_VERSION%%/site-packages/compiler/future.pyo
-lib/%%PYTHON_VERSION%%/site-packages/compiler/misc.py
-lib/%%PYTHON_VERSION%%/site-packages/compiler/misc.pyc
-lib/%%PYTHON_VERSION%%/site-packages/compiler/misc.pyo
-lib/%%PYTHON_VERSION%%/site-packages/compiler/pyassem.py
-lib/%%PYTHON_VERSION%%/site-packages/compiler/pyassem.pyc
-lib/%%PYTHON_VERSION%%/site-packages/compiler/pyassem.pyo
-lib/%%PYTHON_VERSION%%/site-packages/compiler/pycodegen.py
-lib/%%PYTHON_VERSION%%/site-packages/compiler/pycodegen.pyc
-lib/%%PYTHON_VERSION%%/site-packages/compiler/pycodegen.pyo
-lib/%%PYTHON_VERSION%%/site-packages/compiler/symbols.py
-lib/%%PYTHON_VERSION%%/site-packages/compiler/symbols.pyc
-lib/%%PYTHON_VERSION%%/site-packages/compiler/symbols.pyo
-lib/%%PYTHON_VERSION%%/site-packages/compiler/transformer.py
-lib/%%PYTHON_VERSION%%/site-packages/compiler/transformer.pyc
-lib/%%PYTHON_VERSION%%/site-packages/compiler/transformer.pyo
-lib/%%PYTHON_VERSION%%/site-packages/compiler/visitor.py
-lib/%%PYTHON_VERSION%%/site-packages/compiler/visitor.pyc
-lib/%%PYTHON_VERSION%%/site-packages/compiler/visitor.pyo
-@dirrm lib/%%PYTHON_VERSION%%/site-packages/compiler