aboutsummaryrefslogtreecommitdiff
path: root/lang/py-prolog/files/patch-setup.py
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2020-01-27 15:34:18 +0000
committerRene Ladan <rene@FreeBSD.org>2020-01-27 15:34:18 +0000
commitaa2769119334a5045d38419995aca597ea24b1f1 (patch)
tree46f389d2a7bc016aa58737ba87b33fe1dfdfd3fe /lang/py-prolog/files/patch-setup.py
parentad735287aef46d649c1c08ea3d049288113148cb (diff)
downloadports-aa2769119334a5045d38419995aca597ea24b1f1.tar.gz
ports-aa2769119334a5045d38419995aca597ea24b1f1.zip
Notes
Diffstat (limited to 'lang/py-prolog/files/patch-setup.py')
-rw-r--r--lang/py-prolog/files/patch-setup.py43
1 files changed, 0 insertions, 43 deletions
diff --git a/lang/py-prolog/files/patch-setup.py b/lang/py-prolog/files/patch-setup.py
deleted file mode 100644
index e52d946659f0..000000000000
--- a/lang/py-prolog/files/patch-setup.py
+++ /dev/null
@@ -1,43 +0,0 @@
---- setup.py.orig 2001-06-10 07:16:04.000000000 +0400
-+++ setup.py 2011-10-09 11:20:52.000000000 +0400
-@@ -5,7 +5,7 @@
- import os
-
- def get_atom(atom):
-- query = "pl -f none -g 'current_prolog_flag(%s, V), write(V), nl.' -t 'halt'"
-+ query = "swipl -f none -g 'current_prolog_flag(%s, V), write(V), nl.' -t 'halt'"
- f = os.popen(query % atom)
- r = f.read()[:-1]
- f.close()
-@@ -13,11 +13,13 @@
-
- # TDB: this code only need run during 'build'.
- arch = get_atom('arch')
--#swipl_version = get_atom('version')
-+swipl_version = get_atom('version')
- swipl_home = get_atom('home')
- #print 'P>', arch, swipl_version, swipl_home
- swipl_include_path = os.path.join(swipl_home, 'include')
- swipl_library_path = os.path.join(swipl_home, 'runtime', arch)
-+if swipl_version > '50400':
-+ swipl_library_path = os.path.join(swipl_home, 'lib', arch)
- #print 'I>', swipl_include_path, swipl_library_path
-
- setup(name="PyProlog",
-@@ -25,7 +27,7 @@
- author="Glen Wilder",
- author_email="gwilder@best.com",
- url="http://pyprolog.sourceforge.net",
-- licence='LGPL',
-+ license='LGPL',
- description='SWI-Prolog extension module',
- packages=["pyprolog"],
- package_dir={"pyprolog":"Lib"},
-@@ -34,6 +36,6 @@
- ["Modules/swiplmodule.c"],
- include_dirs=[swipl_include_path],
- library_dirs=[swipl_library_path],
-- libraries=['pl', 'termcap'])
-+ libraries=['swipl', 'termcap'])
- ]
- )