aboutsummaryrefslogtreecommitdiff
path: root/lang/pypy3
diff options
context:
space:
mode:
authorDavid Naylor <dbn@FreeBSD.org>2017-06-18 16:55:38 +0000
committerDavid Naylor <dbn@FreeBSD.org>2017-06-18 16:55:38 +0000
commitbe9819f737564d904fb9983cbc54aa0407dd9a35 (patch)
tree93d34148942316232d82eb782ffbe503aae7c787 /lang/pypy3
parent795c8e51a0fc77ed98c41bcd0f34f5ce54ad67cb (diff)
downloadports-be9819f737564d904fb9983cbc54aa0407dd9a35.tar.gz
ports-be9819f737564d904fb9983cbc54aa0407dd9a35.zip
Notes
Diffstat (limited to 'lang/pypy3')
-rw-r--r--lang/pypy3/Makefile2
-rw-r--r--lang/pypy3/distinfo6
-rw-r--r--lang/pypy3/files/patch-rpython_rlib_rvmprof_src_shared_machine.c20
-rw-r--r--lang/pypy3/files/patch-rpython_translator_platform_posix.py13
4 files changed, 23 insertions, 18 deletions
diff --git a/lang/pypy3/Makefile b/lang/pypy3/Makefile
index bbba8e7b7460..5576668d579e 100644
--- a/lang/pypy3/Makefile
+++ b/lang/pypy3/Makefile
@@ -2,8 +2,6 @@
# $FreeBSD$
PORTNAME= pypy3
-DISTVERSION= 5.7.1
-PORTREVISION= 2
DISTNAME= ${PORTNAME}-v${DISTVERSION}-src
MASTERDIR= ${.CURDIR}/../pypy
diff --git a/lang/pypy3/distinfo b/lang/pypy3/distinfo
index ad2e5764da74..c1b13d61d4f7 100644
--- a/lang/pypy3/distinfo
+++ b/lang/pypy3/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1491510361
-SHA256 (pypy3-v5.7.1-src.tar.bz2) = 40ece0145282980ac121390f13709404c0532896507d5767496381180b631bd0
-SIZE (pypy3-v5.7.1-src.tar.bz2) = 28811162
+TIMESTAMP = 1497478958
+SHA256 (pypy3-v5.8.0-src.tar.bz2) = 9d090127335c3c0fd2b14c8835bf91752e62756e55ea06aad3353f24a6854223
+SIZE (pypy3-v5.8.0-src.tar.bz2) = 28986883
diff --git a/lang/pypy3/files/patch-rpython_rlib_rvmprof_src_shared_machine.c b/lang/pypy3/files/patch-rpython_rlib_rvmprof_src_shared_machine.c
new file mode 100644
index 000000000000..b4e9cbbbeeea
--- /dev/null
+++ b/lang/pypy3/files/patch-rpython_rlib_rvmprof_src_shared_machine.c
@@ -0,0 +1,20 @@
+--- rpython/rlib/rvmprof/src/shared/machine.c.orig 2017-06-05 20:40:44 UTC
++++ rpython/rlib/rvmprof/src/shared/machine.c
+@@ -28,6 +28,8 @@ const char * vmp_machine_os_name(void)
+ #endif
+ #elif __linux__
+ return "linux";
++#elif __FreeBSD__
++ return "freebsd";
+ #else
+ #error "Unknown compiler"
+ #endif
+@@ -39,7 +41,7 @@ long vmp_fd_to_path(int fd, char * buffe
+ char proffs[24];
+ (void)snprintf(proffs, 24, "/proc/self/fd/%d", fd);
+ return readlink(proffs, buffer, buffer_len);
+-#elif defined(VMPROF_UNIX)
++#elif defined(VMPROF_UNIX) && !defined(__FreeBSD__)
+ fcntl(fd, F_GETPATH, buffer);
+ return strlen(buffer);
+ #endif
diff --git a/lang/pypy3/files/patch-rpython_translator_platform_posix.py b/lang/pypy3/files/patch-rpython_translator_platform_posix.py
deleted file mode 100644
index 9d202772422e..000000000000
--- a/lang/pypy3/files/patch-rpython_translator_platform_posix.py
+++ /dev/null
@@ -1,13 +0,0 @@
-FreeBSD's base ld(1) does not currently support plugins and is not compatible
-with clang's link-time optimisation.
---- rpython/translator/platform/posix.py.orig 2017-04-03 06:36:13 UTC
-+++ rpython/translator/platform/posix.py
-@@ -132,7 +132,7 @@ class BasePosix(Platform):
-
- # xxx check which compilers accept this option or not
- if not config or config.translation.gcrootfinder != 'asmgcc':
-- cflags = ('-flto',) + cflags
-+ pass
-
- m = GnuMakefile(path)
- m.exe_name = path.join(exe_name.basename)