aboutsummaryrefslogtreecommitdiff
path: root/lang/pypy
diff options
context:
space:
mode:
authorDavid Naylor <dbn@FreeBSD.org>2016-03-14 04:04:51 +0000
committerDavid Naylor <dbn@FreeBSD.org>2016-03-14 04:04:51 +0000
commitce3389dc2d61773cc144d0ed09a211cba0ac442e (patch)
tree46c037814f27f371e73eeccc1a3ab371cdfccf83 /lang/pypy
parent51dc3919745151a18c4d1bd4801153a2febc6af6 (diff)
downloadports-ce3389dc2d61773cc144d0ed09a211cba0ac442e.tar.gz
ports-ce3389dc2d61773cc144d0ed09a211cba0ac442e.zip
Notes
Diffstat (limited to 'lang/pypy')
-rw-r--r--lang/pypy/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/lang/pypy/Makefile b/lang/pypy/Makefile
index 66aa63794861..fbae428c49bb 100644
--- a/lang/pypy/Makefile
+++ b/lang/pypy/Makefile
@@ -19,15 +19,18 @@ TEST_DEPENDS= ${PREFIX}/${PYPY_DIR}/lib_pypy/_gdbm_cffi.pypy-${PYPY_CFFI_VER}.so
ONLY_FOR_ARCHS= i386 amd64 armv6 powerpc64
ONLY_FOR_ARCHS_REASON= PyPy JIT only supported on these architectures
+OPTIONS_SINGLE= TRANS
+OPTIONS_SINGLE_TRANS= PYTHON
PYTHON_DESC= Use Python-2.7 to translate (slowest)
PYPY_DESC= Use PyPy to translate (fastest, highest memory usage)
PYPY_MINMEM_DESC= Use PyPy to translate (lowest memory usage)
TRANS_DESC= Translation method
LOCALBASE?= /usr/local
.if exists(${LOCALBASE}/bin/pypy)
-OPTIONS_SINGLE= TRANS
-OPTIONS_SINGLE_TRANS= PYTHON PYPY PYPY_MINMEM
-OPTIONS_DEFAULT+= PYPY_MINMEM
+OPTIONS_DEFAULT= PYPY_MINMEM
+OPTIONS_SINGLE_TRANS+= PYPY PYPY_MINMEM
+.else
+OPTIONS_SLAVE= PYTHON
.endif
CONFLICTS_INSTALL= pypy3-[0-9]*