aboutsummaryrefslogtreecommitdiff
path: root/lang/python+ipv6/Makefile
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2000-04-28 03:12:52 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2000-04-28 03:12:52 +0000
commit1008113c4bf886bb734f66d656fd76d05484629e (patch)
tree71845b33c2e987443ac977acdd52dee7f789b646 /lang/python+ipv6/Makefile
parentff47144d7a77092da178772926ce1602217bc3ac (diff)
Notes
Diffstat (limited to 'lang/python+ipv6/Makefile')
-rw-r--r--lang/python+ipv6/Makefile34
1 files changed, 11 insertions, 23 deletions
diff --git a/lang/python+ipv6/Makefile b/lang/python+ipv6/Makefile
index c37b0f305bd6..227d4e0db4d8 100644
--- a/lang/python+ipv6/Makefile
+++ b/lang/python+ipv6/Makefile
@@ -7,7 +7,7 @@
PORTNAME= python+ipv6
PORTVERSION= 1.5.2
-CATEGORIES= lang python tk82 ipv6
+CATEGORIES= lang python ipv6
MASTER_SITES= ftp://www.python.org/pub/python/src/ \
ftp://ftp.cwi.nl/pub/python/src/
DISTNAME= py152
@@ -19,8 +19,6 @@ PATCH_DIST_STRIP= -p1
MAINTAINER= sumikawa@FreeBSD.org
-LIB_DEPENDS= ${TK_DEPENDS}
-
DIST_SUBDIR= python
WRKSRC= ${WRKDIR}/Python-1.5.2
GNU_CONFIGURE= yes
@@ -35,18 +33,6 @@ MAN1= python.1
#
SETUP_FILE= Setup
-.include <bsd.port.pre.mk>
-
-#
-# Support for Tk is compiled in by default only if X11 is installed.
-#
-.if defined(WITH_TK) || (exists(${X11BASE}/lib/libX11.a) \
- && !defined(WITHOUT_TK))
-TK_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82
-SETUP_LOCAL= Setup.tk
-PLIST_TK= ${PKGDIR}/PLIST.tk
-.endif
-
#
# If you want to use Python's thread module, you need to set WITH_THREADS
# to 'yes', and you must have the FreeBSD threading c library (libc_r)
@@ -80,6 +66,7 @@ PLIST_TOOLS= ${PKGDIR}/PLIST.Tools
post-extract:
cd ${WRKSRC}/Lib && ${SH} ${FILESDIR}/plat-freebsd4.sh
+ cd ${WRKSRC}/Lib && ${SH} ${FILESDIR}/plat-freebsd5.sh
post-configure:
${CP} ${FILESDIR}/${SETUP_FILE} ${WRKSRC}/Modules/Setup
@@ -87,6 +74,8 @@ post-configure:
${CAT} ${FILESDIR}/${file} >> ${WRKSRC}/Modules/Setup.local
.endfor
+.include <bsd.port.pre.mk>
+
.if ${OSVERSION} >= 400014
PLIST_V6= ${PKGDIR}/PLIST.v6
CONFIGURE_ARGS+=--enable-ipv6
@@ -94,12 +83,14 @@ CONFIGURE_ARGS+=--enable-ipv6
CONFIGURE_ARGS+=--disable-ipv6
.endif
-.if ${OSVERSION} >= 400000
-PLATFORMS=plat-freebsd2 plat-freebsd3
+.if ${OSVERSION} >= 500000
+PLATFORMS=plat-freebsd2 plat-freebsd3 plat-freebsd4
+.elif ${OSVERSION} >= 400000
+PLATFORMS=plat-freebsd2 plat-freebsd3 plat-freebsd5
.elif ${OSVERSION} >= 300000
-PLATFORMS=plat-freebsd2 plat-freebsd4
-.else
-PLATFORMS=plat-freebsd3 plat-freebsd4
+PLATFORMS=plat-freebsd2 plat-freebsd4 plat-freebsd5
+.else
+PLATFORMS=plat-freebsd3 plat-freebsd4 plat-freebsd5
.endif
pre-install:
@@ -121,8 +112,5 @@ post-install:
@cd ${WRKSRC}; tar cf - Tools | \
(cd ${PREFIX}/lib/python1.5; tar xf -)
.endif
-.if ${OSVERSION} >= 400014
- ${INSTALL_DATA} ${WRKSRC}/README.v6 ${PREFIX}/share/doc/python
-.endif
.include <bsd.port.post.mk>