aboutsummaryrefslogtreecommitdiff
path: root/lang/python+ipv6
diff options
context:
space:
mode:
authorJeremy Lea <reg@FreeBSD.org>2000-04-17 00:19:02 +0000
committerJeremy Lea <reg@FreeBSD.org>2000-04-17 00:19:02 +0000
commitb4455771cced2fe9f134e751fe88dbba7226e694 (patch)
tree39733bef5e1d466d30938b5a47f0b46a7b6890b4 /lang/python+ipv6
parent877b8a533b44bb6324ebbaf65cd80a60d1572003 (diff)
downloadports-b4455771cced2fe9f134e751fe88dbba7226e694.tar.gz
ports-b4455771cced2fe9f134e751fe88dbba7226e694.zip
Notes
Diffstat (limited to 'lang/python+ipv6')
-rw-r--r--lang/python+ipv6/Makefile19
1 files changed, 7 insertions, 12 deletions
diff --git a/lang/python+ipv6/Makefile b/lang/python+ipv6/Makefile
index a232dfa82695..c37b0f305bd6 100644
--- a/lang/python+ipv6/Makefile
+++ b/lang/python+ipv6/Makefile
@@ -35,13 +35,13 @@ MAN1= python.1
#
SETUP_FILE= Setup
+.include <bsd.port.pre.mk>
+
#
# Support for Tk is compiled in by default only if X11 is installed.
#
-.if exists(${X11BASE})
-WITH_TK?= yes
-.endif
-.if defined(WITH_TK) && $(WITH_TK) == yes
+.if defined(WITH_TK) || (exists(${X11BASE}/lib/libX11.a) \
+ && !defined(WITHOUT_TK))
TK_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82
SETUP_LOCAL= Setup.tk
PLIST_TK= ${PKGDIR}/PLIST.tk
@@ -54,11 +54,9 @@ PLIST_TK= ${PKGDIR}/PLIST.tk
#
# This option is enabled by default.
#
-WITH_THREADS?= yes
LIBC_R!= /sbin/ldconfig -r | grep c_r || true
-.if ${LIBC_R} != "" && defined(WITH_THREADS) && ${WITH_THREADS} == yes
+.if (${LIBC_R} != "") && !defined(WITHOUT_THREADS)
CONFIGURE_ARGS+= --with-thread
-
CFLAGS+= -D_THREAD_SAFE
CONFIGURE_ENV+= LDFLAGS="-pthread ${LDFLAGS}"
.endif
@@ -76,8 +74,7 @@ PLIST_GMP= ${PKGDIR}/PLIST.gmp
# to a web tree checker, to a collection of simple scripts that are useful
# while extending or managing Python.
#
-WITH_TOOLS?= yes
-.if defined(WITH_TOOLS) && ${WITH_TOOLS} == yes
+.if !defined(WITHOUT_TOOLS)
PLIST_TOOLS= ${PKGDIR}/PLIST.Tools
.endif
@@ -90,8 +87,6 @@ post-configure:
${CAT} ${FILESDIR}/${file} >> ${WRKSRC}/Modules/Setup.local
.endfor
-.include <bsd.port.pre.mk>
-
.if ${OSVERSION} >= 400014
PLIST_V6= ${PKGDIR}/PLIST.v6
CONFIGURE_ARGS+=--enable-ipv6
@@ -122,7 +117,7 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/Misc/python-mode.el ${PREFIX}/share/emacs/site-lisp
${INSTALL_DATA} ${WRKSRC}/Misc/COPYRIGHT ${PREFIX}/share/doc/python
@${MKDIR} ${PREFIX}/lib/python1.5/site-packages
-.if defined(WITH_TOOLS) && ${WITH_TOOLS} == yes
+.if !defined(WITHOUT_TOOLS)
@cd ${WRKSRC}; tar cf - Tools | \
(cd ${PREFIX}/lib/python1.5; tar xf -)
.endif