aboutsummaryrefslogtreecommitdiff
path: root/lang/python/Makefile
diff options
context:
space:
mode:
authorAlexander Botero-Lowry <alexbl@FreeBSD.org>2007-07-30 09:42:28 +0000
committerAlexander Botero-Lowry <alexbl@FreeBSD.org>2007-07-30 09:42:28 +0000
commit4942ce5a7d8a3d0cbebaf4d202011850d1f7569f (patch)
treedb1f21912f461000d609ddcd5d130946bcfe9e09 /lang/python/Makefile
parentb4be9b354e86bd790925c5a9a2e67df8ba20bc00 (diff)
downloadports-4942ce5a7d8a3d0cbebaf4d202011850d1f7569f.tar.gz
ports-4942ce5a7d8a3d0cbebaf4d202011850d1f7569f.zip
Notes
Diffstat (limited to 'lang/python/Makefile')
-rw-r--r--lang/python/Makefile41
1 files changed, 21 insertions, 20 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index fc1b1a72cc79..3b3a59fc5dd3 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -6,43 +6,44 @@
#
PORTNAME= python
-PORTVERSION= 2.4.4
-PORTEPOCH= 1
+PORTVERSION= ${PYTHON_VER}
+PORTEPOCH= 2
CATEGORIES= lang python ipv6
MASTER_SITES= # empty
DISTFILES= # empty
EXTRACT_ONLY= # empty
MAINTAINER= python@FreeBSD.org
-COMMENT= The "meta-port" for the stable version of Python interpreter
+COMMENT= The "meta-port" for the default version of Python interpreter
USE_PYTHON_RUN= yes
-PYTHON_VERSION= python2.4
+PYTHON_VERSION= ${PYTHON_DEFAULT_VERSION}
NO_BUILD= yes
-do-install: # empty
+do-install:
+ @${DO_NADA}
# Major upgrade support
PORTUPGRADE?= ${LOCALBASE}/sbin/portupgrade
PKG_WHICH?= ${LOCALBASE}/sbin/pkg_which
upgrade-site-packages:
- @if [ -x ${PORTUPGRADE} ]; then \
- for ver in 2.1 2.2 2.3 2.5; do \
- if [ -d ${PREFIX}/lib/python$$ver ]; then \
- UPD=`${FIND} ${PREFIX}/lib/python$$ver \
- -type f -print0 | \
- ${XARGS} -0 ${PKG_WHICH} | \
- ${GREP} -Fv '?' | \
- ${EGREP} -v '^python2?[0-5]?-2' | \
- ${SORT} -u`; \
- if [ "$$UPD" ]; then \
- ${PORTUPGRADE} -f $$UPD; \
- fi; \
- fi; \
- done; \
- else \
+ @if [ ! -x ${PORTUPGRADE} ]; then \
${ECHO_MSG} "Please install ports-mgmt/portupgrade."; \
${FALSE}; \
fi
+ @for ver in `echo ${_PYTHON_ALLBRANCHES}|${SED} 's/${PYTHON_VER}//'`; do \
+ if [ -d ${PREFIX}/lib/python$$ver ]; then \
+ UPD=`${FIND} ${PREFIX}/lib/python$$ver \
+ -type f -print0 | \
+ ${XARGS} -0 ${PKG_WHICH} | \
+ ${GREP} -Fv '?' | \
+ ${EGREP} -v '^python2?[0-5]?-2' | \
+ ${SORT} -u`; \
+ if [ "$$UPD" ]; then \
+ ${PORTUPGRADE} -f $$UPD; \
+ fi; \
+ fi; \
+ done \
+
.include <bsd.port.mk>