aboutsummaryrefslogtreecommitdiff
path: root/lang/python23/Makefile
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2003-09-24 11:07:22 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2003-09-24 11:07:22 +0000
commitac5bea628507387760983e46c937773f49f86d4d (patch)
tree0e8ee311b51c5e2d172f27c7e757e79e0ef07c1c /lang/python23/Makefile
parent70bf2d8a3f92ddd01cdcdcf2b7be3b4209630ca6 (diff)
Notes
Diffstat (limited to 'lang/python23/Makefile')
-rw-r--r--lang/python23/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/lang/python23/Makefile b/lang/python23/Makefile
index e0ddbf78e425..386618c09faf 100644
--- a/lang/python23/Makefile
+++ b/lang/python23/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= python
-PORTVERSION= 2.3
-PORTREVISION= 1
+PORTVERSION= 2.3.1
CATEGORIES= lang python ipv6
MASTER_SITES= ${MASTER_SITE_PYTHON}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
@@ -71,6 +70,9 @@ PLIST_SUB+= X86_ONLY=""
.else
PLIST_SUB+= X86_ONLY="@comment "
.endif
+.if ${ARCH} == amd64
+CFLAGS+= -fPIC
+.endif
.if ${OSVERSION} < 400000
LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
@@ -111,6 +113,10 @@ post-patch:
${REINPLACE_CMD} -e \
's,/usr/doc/python-docs-,${PREFIX}/share/doc/python,g' \
${WRKSRC}/Lib/pydoc.py
+.if ${ARCH} == amd64 || ${ARCH} == sparc64
+ ${REINPLACE_CMD} -e \
+ 's,^#\(dl .*\),\1,' ${WRKSRC}/Modules/Setup.dist
+.endif
pre-install:
.for platform in ${PLATFORMS}