aboutsummaryrefslogtreecommitdiff
path: root/lang/python23/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2009-07-14 09:29:03 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2009-07-14 09:29:03 +0000
commit2b97db48a68c3b2a8a000fa53a14006421f7d092 (patch)
tree2ffb74e2ec09e73b3ff7d3225bd0d4e653ce4f4b /lang/python23/Makefile
parent1be0ee9179ba54982fb2172e963126f343169b60 (diff)
downloadports-2b97db48a68c3b2a8a000fa53a14006421f7d092.tar.gz
ports-2b97db48a68c3b2a8a000fa53a14006421f7d092.zip
Notes
Diffstat (limited to 'lang/python23/Makefile')
-rw-r--r--lang/python23/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/lang/python23/Makefile b/lang/python23/Makefile
index ef8b97b4f1e5..491e952df40d 100644
--- a/lang/python23/Makefile
+++ b/lang/python23/Makefile
@@ -7,6 +7,7 @@
PORTNAME= python23
PORTVERSION= 2.3.7
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -49,7 +50,7 @@ OPTIONS= THREADS "Enable thread support" on \
.include <bsd.port.pre.mk>
-.if ${PYTHON_VERSION} == ${PYTHON_DEFAULT_VERSION}
+.if ${PYTHON_VERSION} == ${PYTHON_DEFAULT_VERSION} || !exists(${LOCALBASE}/bin/python)
MLINKS= ${PYTHON_VERSION}.1 python.1
PLIST_SUB+= IF_DEFAULT=""
.else
@@ -171,7 +172,7 @@ post-install:
${INSTALL_SCRIPT} ${WRKDIR}/pydoc2.3 ${WRKDIR}/idle2.3 \
${PREFIX}/bin
-.if ${PYTHON_VERSION} == ${PYTHON_DEFAULT_VERSION}
+.if ${PYTHON_VERSION} == ${PYTHON_DEFAULT_VERSION} || !exists(${LOCALBASE}/bin/python)
for f in ${BIN_SCRIPTS}; do \
TARGET=`${ECHO_CMD} $$f | ${SED} -E ${BINLINKS_SUB}`; \
cd ${PREFIX}/bin && ${LN} -f $$TARGET $$f; \