aboutsummaryrefslogtreecommitdiff
path: root/lang/python23/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2000-11-29 12:35:31 +0000
committerThomas Gellekum <tg@FreeBSD.org>2000-11-29 12:35:31 +0000
commite3c1c82e91b5d46c3b4e90c7f7a431e2a7952f5f (patch)
treeaccd7cadde8887f72d8ec456de32af8d639771b7 /lang/python23/Makefile
parentfb2cbc9afbd5a2a9b88a859de2ce5956225ef564 (diff)
downloadports-e3c1c82e91b5d46c3b4e90c7f7a431e2a7952f5f.tar.gz
ports-e3c1c82e91b5d46c3b4e90c7f7a431e2a7952f5f.zip
Notes
Diffstat (limited to 'lang/python23/Makefile')
-rw-r--r--lang/python23/Makefile19
1 files changed, 16 insertions, 3 deletions
diff --git a/lang/python23/Makefile b/lang/python23/Makefile
index 6663762a106f..b2b09aad12a8 100644
--- a/lang/python23/Makefile
+++ b/lang/python23/Makefile
@@ -68,6 +68,14 @@ PLIST_GMP= ${PKGDIR}/pkg-plist.gmp
PLIST_TOOLS= ${PKGDIR}/pkg-plist.Tools
.endif
+#
+# Install Demo/ by default.
+#
+.if !defined(WITHOUT_DEMO)
+PLIST_DEMO= ${PKGDIR}/pkg-plist.Demo
+DEMODIR= ${PREFIX}/share/examples/python
+.endif
+
post-configure:
${CP} ${FILESDIR}/${SETUP_FILE} ${WRKSRC}/Modules/Setup
.for file in ${SETUP_LOCAL}
@@ -107,16 +115,21 @@ pre-install:
${PREFIX}/lib/${PYTHON_VERSION}/${platform}/
.endfor
.endfor
- @sort -r -o ${PLIST} ${PLIST_GMP} ${PLIST_TOOLS} ${PKGDIR}/pkg-plist
+ @sort -r -o ${PLIST} ${PLIST_GMP} ${PLIST_TOOLS} ${PLIST_DEMO} ${PKGDIR}/pkg-plist
post-install:
strip ${PREFIX}/bin/python
@${MKDIR} ${PREFIX}/share/emacs/site-lisp
${INSTALL_DATA} ${WRKSRC}/Misc/python-mode.el ${PREFIX}/share/emacs/site-lisp
- @${MKDIR} ${PREFIX}/lib/${PYTHON_VERSION}/site-packages
+ @${MKDIR} ${PYTHON_SITELIBDIR}
.if !defined(WITHOUT_TOOLS)
@cd ${WRKSRC}; tar -c --exclude='*CVS*' -f - Tools | \
- (cd ${PREFIX}/lib/${PYTHON_VERSION}; tar xf -)
+ (cd ${PYTHON_LIBDIR}; tar xf -)
+.endif
+.if !defined(WITHOUT_DEMO)
+ @${MKDIR} ${DEMODIR}
+ @cd ${WRKSRC}/Demo; tar -c --exclude='*CVS*' -f - * | \
+ (cd ${DEMODIR}; tar xf -)
.endif
.include <bsd.port.post.mk>