aboutsummaryrefslogtreecommitdiff
path: root/lang/python23/files
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2003-07-31 19:34:54 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2003-07-31 19:34:54 +0000
commitd6fb067853c11afb8796aa09ef04b3a5e3c1b72e (patch)
tree2069a2f20a15715d41d2b894e3e2a57f8ceff9e8 /lang/python23/files
parente56fbbbb5c3ec0a1310dccba4bc33174aa11cd68 (diff)
Notes
Diffstat (limited to 'lang/python23/files')
-rw-r--r--lang/python23/files/patch-configure15
-rw-r--r--lang/python23/files/patch-setup.py14
2 files changed, 22 insertions, 7 deletions
diff --git a/lang/python23/files/patch-configure b/lang/python23/files/patch-configure
new file mode 100644
index 000000000000..c17e753795a5
--- /dev/null
+++ b/lang/python23/files/patch-configure
@@ -0,0 +1,15 @@
+--- configure.orig Sun Jul 13 18:46:13 2003
++++ configure Sat Jul 19 15:21:09 2003
+@@ -3288,6 +3288,12 @@
+ RUNSHARED=LD_LIBRARY_PATH=`pwd`:$LD_LIBRARY_PATH
+ INSTSONAME="$LDLIBRARY".$SOVERSION
+ ;;
++ FreeBSD*)
++ LDLIBRARY='libpython$(VERSION).so'
++ BLDLIBRARY='-L. -lpython$(VERSION)'
++ RUNSHARED=LD_LIBRARY_PATH=`pwd`:$LD_LIBRARY_PATH
++ INSTSONAME="$LDLIBRARY"
++ ;;
+ hp*|HP*)
+ LDLIBRARY='libpython$(VERSION).sl'
+ BLDLIBRARY='-Wl,+b,$(LIBDIR) -L. -lpython$(VERSION)'
diff --git a/lang/python23/files/patch-setup.py b/lang/python23/files/patch-setup.py
index f3cef489fa8f..139ea97743d5 100644
--- a/lang/python23/files/patch-setup.py
+++ b/lang/python23/files/patch-setup.py
@@ -1,11 +1,11 @@
---- setup.py.orig Fri Mar 2 07:24:14 2001
-+++ setup.py Mon Mar 5 15:26:17 2001
-@@ -14,7 +14,7 @@
- from distutils.command.build_ext import build_ext
+--- setup.py.orig Thu Jul 10 21:48:39 2003
++++ setup.py Sat Jul 19 16:27:04 2003
+@@ -15,7 +15,7 @@
+ from distutils.command.install_lib import install_lib
# This global variable is used to hold the list of modules to be disabled.
-disabled_module_list = []
-+disabled_module_list = ["_tkinter", "gdbm", "mpz", "pyexpat"]
++disabled_module_list = ["_bsddb", "_tkinter", "gdbm", "mpz", "pyexpat"]
- def find_file(filename, std_dirs, paths):
- """Searches for the directory where a given file is located,
+ def add_dir_to_list(dirlist, dir):
+ """Add the directory 'dir' to the list 'dirlist' (at the front) if