aboutsummaryrefslogtreecommitdiff
path: root/lang/python23
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2004-05-27 15:58:02 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2004-05-27 15:58:02 +0000
commit7866c5194c5f15d90bbb54820bb31a69998c6bed (patch)
treeeb238db7252a16aab5fb4ffc996c86d0e23c9d2f /lang/python23
parent6827c0bb527a77eeec4ae30b5ceb4a9ad68715db (diff)
downloadports-7866c5194c5f15d90bbb54820bb31a69998c6bed.tar.gz
ports-7866c5194c5f15d90bbb54820bb31a69998c6bed.zip
Notes
Diffstat (limited to 'lang/python23')
-rw-r--r--lang/python23/Makefile9
-rw-r--r--lang/python23/distinfo2
-rw-r--r--lang/python23/files/patch-Objects::intobject.c12
-rw-r--r--lang/python23/files/patch-Objects::weakrefobject.c65
-rw-r--r--lang/python23/files/patch-configure8
-rw-r--r--lang/python23/pkg-plist2
6 files changed, 7 insertions, 91 deletions
diff --git a/lang/python23/Makefile b/lang/python23/Makefile
index 149b35f9877d..59648c58b0c8 100644
--- a/lang/python23/Makefile
+++ b/lang/python23/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= python
-PORTVERSION= 2.3.3
-PORTREVISION= 5
+PORTVERSION= 2.3.4
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -40,12 +39,12 @@ TOOLSDIR= ${PREFIX}/share/${PYTHON_VERSION}
OPTIONS= THREADS "Enable thread support" on \
HUGE_STACK_SIZE "Use a larger thread stack" off \
- UCS2 "Use UCS2 instead of UCS4 for unicode support" off \
+ UCS4 "Use UCS4 for unicode support" on \
PYMALLOC "Uses python's internal malloc" on
.include <bsd.port.pre.mk>
-.if defined(WITH_THREADS)
+.if !defined(WITHOUT_THREADS)
CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
.if defined(WITHOUT_HUGE_STACK_SIZE)
@@ -61,7 +60,7 @@ CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
.endif # defined(LDFLAGS)
.endif # defined(WITH_THREADS)
-.if defined(WITHOUT_UCS2)
+.if !defined(WITHOUT_UCS4) && !defined(WITH_UCS2)
CONFIGURE_ARGS+= --enable-unicode=ucs4
.endif
diff --git a/lang/python23/distinfo b/lang/python23/distinfo
index 459b99fd3e56..36a4686946c8 100644
--- a/lang/python23/distinfo
+++ b/lang/python23/distinfo
@@ -15,6 +15,8 @@ MD5 (python/Python-2.3.1.tgz) = a3dcbe1c7f173c8e3c7cce28495016ae
MD5 (python/Python-2.3.2.tgz) = f54d7a529d444994b4b33429bbb45479
MD5 (python/Python-2.3.3.tgz) = 4d16732b1cfccc0ed250956d41463c61
SIZE (python/Python-2.3.3.tgz) = 8491380
+MD5 (python/Python-2.3.4.tgz) = b6cf0b19226861a38689d2fabd0931b3
+SIZE (python/Python-2.3.4.tgz) = 8502738
MD5 (python/Python-2.4.a0.20040106.tgz) = cde5962028bcfdb473455c57bbb24c18
MD5 (python/Python-2.4.a0.20040311.tgz) = 5619b787ce62a1ebac3c973179d36670
SIZE (python/Python-2.4.a0.20040311.tgz) = 8512702
diff --git a/lang/python23/files/patch-Objects::intobject.c b/lang/python23/files/patch-Objects::intobject.c
deleted file mode 100644
index 05983721a6cb..000000000000
--- a/lang/python23/files/patch-Objects::intobject.c
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -u python/dist/src/Objects/intobject.c:2.105 python/dist/src/Objects/intobject.c:2.105.8.1
---- Objects/intobject.c:2.105 Sat Jun 28 13:04:24 2003
-+++ Objects/intobject.c Sun Feb 8 10:56:07 2004
-@@ -1080,7 +1080,7 @@
- int ival;
- #if NSMALLNEGINTS + NSMALLPOSINTS > 0
- for (ival = -NSMALLNEGINTS; ival < NSMALLPOSINTS; ival++) {
-- if ((free_list = fill_free_list()) == NULL)
-+ if (!free_list && (free_list = fill_free_list()) == NULL)
- return 0;
- /* PyObject_New is inlined */
- v = free_list;
diff --git a/lang/python23/files/patch-Objects::weakrefobject.c b/lang/python23/files/patch-Objects::weakrefobject.c
deleted file mode 100644
index 13789fbde97f..000000000000
--- a/lang/python23/files/patch-Objects::weakrefobject.c
+++ /dev/null
@@ -1,65 +0,0 @@
-diff -u python/dist/src/Objects/weakrefobject.c:1.13.6.1 python/dist/src/Objects/weakrefobject.c:1.13.6.3
---- Objects/weakrefobject.c:1.13.6.1 Thu Nov 20 14:13:51 2003
-+++ Objects/weakrefobject.c Wed Feb 4 15:13:43 2004
-@@ -624,20 +624,29 @@
- }
- list = GET_WEAKREFS_LISTPTR(ob);
- get_basic_refs(*list, &ref, &proxy);
-- if (callback == NULL || callback == Py_None)
-+ if (callback == Py_None)
-+ callback = NULL;
-+ if (callback == NULL)
- /* return existing weak reference if it exists */
- result = ref;
- if (result != NULL)
-- Py_XINCREF(result);
-+ Py_INCREF(result);
- else {
-+ /* Note: new_weakref() can trigger cyclic GC, so the weakref
-+ list on ob can be mutated. This means that the ref and
-+ proxy pointers we got back earlier may have been collected,
-+ so we need to compute these values again before we use
-+ them. */
- result = new_weakref(ob, callback);
- if (result != NULL) {
- if (callback == NULL) {
- insert_head(result, list);
- }
- else {
-- PyWeakReference *prev = (proxy == NULL) ? ref : proxy;
-+ PyWeakReference *prev;
-
-+ get_basic_refs(*list, &ref, &proxy);
-+ prev = (proxy == NULL) ? ref : proxy;
- if (prev == NULL)
- insert_head(result, list);
- else
-@@ -664,12 +673,19 @@
- }
- list = GET_WEAKREFS_LISTPTR(ob);
- get_basic_refs(*list, &ref, &proxy);
-+ if (callback == Py_None)
-+ callback = NULL;
- if (callback == NULL)
- /* attempt to return an existing weak reference if it exists */
- result = proxy;
- if (result != NULL)
-- Py_XINCREF(result);
-+ Py_INCREF(result);
- else {
-+ /* Note: new_weakref() can trigger cyclic GC, so the weakref
-+ list on ob can be mutated. This means that the ref and
-+ proxy pointers we got back earlier may have been collected,
-+ so we need to compute these values again before we use
-+ them. */
- result = new_weakref(ob, callback);
- if (result != NULL) {
- PyWeakReference *prev;
-@@ -678,6 +694,7 @@
- result->ob_type = &_PyWeakref_CallableProxyType;
- else
- result->ob_type = &_PyWeakref_ProxyType;
-+ get_basic_refs(*list, &ref, &proxy);
- if (callback == NULL)
- prev = ref;
- else
diff --git a/lang/python23/files/patch-configure b/lang/python23/files/patch-configure
index 40e715f8aa0e..46e70b302d23 100644
--- a/lang/python23/files/patch-configure
+++ b/lang/python23/files/patch-configure
@@ -31,11 +31,3 @@
else
echo "$as_me: program exited with status $ac_status" >&5
echo "$as_me: failed program was:" >&5
-@@ -15001,6 +15007,7 @@
- hints.ai_family = AF_UNSPEC;
- hints.ai_flags = passive ? AI_PASSIVE : 0;
- hints.ai_socktype = SOCK_STREAM;
-+ hints.ai_protocol = IPPROTO_TCP;
- if ((gaierr = getaddrinfo(NULL, "54321", &hints, &aitop)) != 0) {
- (void)gai_strerror(gaierr);
- goto bad;
diff --git a/lang/python23/pkg-plist b/lang/python23/pkg-plist
index fb05501e908a..acbd620b28ea 100644
--- a/lang/python23/pkg-plist
+++ b/lang/python23/pkg-plist
@@ -614,6 +614,7 @@ lib/%%PYTHON_VERSION%%/email/test/data/msg_32.txt
lib/%%PYTHON_VERSION%%/email/test/data/msg_33.txt
lib/%%PYTHON_VERSION%%/email/test/data/msg_34.txt
lib/%%PYTHON_VERSION%%/email/test/data/msg_35.txt
+lib/%%PYTHON_VERSION%%/email/test/data/msg_40.txt
lib/%%PYTHON_VERSION%%/email/test/test_email.py
lib/%%PYTHON_VERSION%%/email/test/test_email.pyc
lib/%%PYTHON_VERSION%%/email/test/test_email.pyo
@@ -1578,7 +1579,6 @@ lib/%%PYTHON_VERSION%%/test/greyrgb.uue
lib/%%PYTHON_VERSION%%/test/output/test_MimeWriter
lib/%%PYTHON_VERSION%%/test/output/test_asynchat
lib/%%PYTHON_VERSION%%/test/output/test_augassign
-lib/%%PYTHON_VERSION%%/test/output/test_binascii
lib/%%PYTHON_VERSION%%/test/output/test_cgi
lib/%%PYTHON_VERSION%%/test/output/test_class
lib/%%PYTHON_VERSION%%/test/output/test_coercion