aboutsummaryrefslogtreecommitdiff
path: root/lang/python23
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-28 07:39:59 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-28 07:39:59 +0000
commita90aa21ef527ad71927e81c1021a17312215f08c (patch)
tree8b3e3d0b132e6e029866dc634c37198c87f0f3b8 /lang/python23
parent17e7e0c3c03c5d69cd9d123471f55afd35661d30 (diff)
downloadports-a90aa21ef527ad71927e81c1021a17312215f08c.tar.gz
ports-a90aa21ef527ad71927e81c1021a17312215f08c.zip
Notes
Diffstat (limited to 'lang/python23')
-rw-r--r--lang/python23/Makefile1
-rw-r--r--lang/python23/files/patch-Lib-test-test_zlib.py14
-rw-r--r--lang/python23/files/patch-Modules-zlibmodule.c13
3 files changed, 28 insertions, 0 deletions
diff --git a/lang/python23/Makefile b/lang/python23/Makefile
index 5dfd1913ecd1..8a250902289c 100644
--- a/lang/python23/Makefile
+++ b/lang/python23/Makefile
@@ -7,6 +7,7 @@
PORTNAME= python23
PORTVERSION= 2.3.6
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
diff --git a/lang/python23/files/patch-Lib-test-test_zlib.py b/lang/python23/files/patch-Lib-test-test_zlib.py
new file mode 100644
index 000000000000..425572d2574d
--- /dev/null
+++ b/lang/python23/files/patch-Lib-test-test_zlib.py
@@ -0,0 +1,14 @@
+--- Lib/test/test_zlib.py 2008/04/08 23:47:30 62234
++++ Lib/test/test_zlib.py 2008/04/09 00:25:17 62235
+@@ -83,6 +83,11 @@
+ # verify failure on building decompress object with bad params
+ self.assertRaises(ValueError, zlib.decompressobj, 0)
+
++ def test_decompressobj_badflush(self):
++ # verify failure on calling decompressobj.flush with bad params
++ self.assertRaises(ValueError, zlib.decompressobj().flush, 0)
++ self.assertRaises(ValueError, zlib.decompressobj().flush, -1)
++
+
+
+ class CompressTestCase(unittest.TestCase):
diff --git a/lang/python23/files/patch-Modules-zlibmodule.c b/lang/python23/files/patch-Modules-zlibmodule.c
new file mode 100644
index 000000000000..7875a40ada7c
--- /dev/null
+++ b/lang/python23/files/patch-Modules-zlibmodule.c
@@ -0,0 +1,13 @@
+--- Modules/zlibmodule.c.orig 2008-04-25 01:47:26.000000000 +0200
++++ Modules/zlibmodule.c 2008-04-25 01:48:17.000000000 +0200
+@@ -774,6 +774,10 @@
+
+ if (!PyArg_ParseTuple(args, "|i:flush", &length))
+ return NULL;
++ if (length <= 0) {
++ PyErr_SetString(PyExc_ValueError, "length must be greater than zero");
++ return NULL;
++ }
+ if (!(retval = PyString_FromStringAndSize(NULL, length)))
+ return NULL;
+