aboutsummaryrefslogtreecommitdiff
path: root/lang/python24/files/patch-setup.py
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2006-10-09 14:29:18 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2006-10-09 14:29:18 +0000
commit1d18bb4fff9ca7e0fca8452b1874fe1f58ffca6f (patch)
tree147f92d454787d912bee658515932bf0eeae4d6c /lang/python24/files/patch-setup.py
parenta109e33441e4540e21473b7b27b9c549e09d3c0e (diff)
- Update the main python version to 2.5.
- Now, lang/python is just a meta-port which depends on lang/python25. - And all versions of Python ports have short version identifier in its package name; python25-2.5, python24-2.4.3 and etc. - Also you must upgrade all python modules after lang/python updated, cd /usr/ports/lang/python && make upgrade-site-packages - Give maintainership of Python ports to the new python@ group which includes me, alexbl@ and others.
Notes
Notes: svn path=/head/; revision=175093
Diffstat (limited to 'lang/python24/files/patch-setup.py')
-rw-r--r--lang/python24/files/patch-setup.py14
1 files changed, 12 insertions, 2 deletions
diff --git a/lang/python24/files/patch-setup.py b/lang/python24/files/patch-setup.py
index 0211a6b3556d..09ac786be1a6 100644
--- a/lang/python24/files/patch-setup.py
+++ b/lang/python24/files/patch-setup.py
@@ -1,5 +1,5 @@
---- setup.py.orig Sat Aug 12 12:46:21 2006
-+++ setup.py Sat Aug 12 12:47:00 2006
+--- setup.py.orig Mon Oct 9 22:08:07 2006
++++ setup.py Mon Oct 9 22:08:42 2006
@@ -15,7 +15,7 @@
from distutils.command.install_lib import install_lib
@@ -27,3 +27,13 @@
curses_libs = ['ncursesw']
exts.append( Extension('_curses', ['_cursesmodule.c'],
libraries = curses_libs) )
+@@ -1187,8 +1187,7 @@
+ ext_modules=[Extension('struct', ['structmodule.c'])],
+
+ # Scripts to install
+- scripts = ['Tools/scripts/pydoc', 'Tools/scripts/idle',
+- 'Lib/smtpd.py']
++ scripts = []
+ )
+
+ # --install-platlib