aboutsummaryrefslogtreecommitdiff
path: root/lang/python24/files
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2007-02-14 06:07:29 +0000
committerXin LI <delphij@FreeBSD.org>2007-02-14 06:07:29 +0000
commitf523e0e7b265ab8b6a383c1ab6bbca36b1fcfcca (patch)
tree2db7ca448c040c63e70aa8d27611867e75592d6a /lang/python24/files
parent971b8d2d5fa090ad845dd0535bb3977b7248506d (diff)
Update to Python 2.4.4.
Approved by: maintainer timeout, alexbl (python@) Tested by: pointyhat PR: ports/105901
Notes
Notes: svn path=/head/; revision=185141
Diffstat (limited to 'lang/python24/files')
-rw-r--r--lang/python24/files/patch-CVE-2006-498067
-rw-r--r--lang/python24/files/patch-setup.py14
2 files changed, 7 insertions, 74 deletions
diff --git a/lang/python24/files/patch-CVE-2006-4980 b/lang/python24/files/patch-CVE-2006-4980
deleted file mode 100644
index 664a96ed1439..000000000000
--- a/lang/python24/files/patch-CVE-2006-4980
+++ /dev/null
@@ -1,67 +0,0 @@
---- Objects/unicodeobject.c 2006/08/22 08:09:11 51465
-+++ Objects/unicodeobject.c 2006/08/22 08:25:33 51466
-@@ -1970,7 +1970,28 @@
-
- static const char *hexdigit = "0123456789abcdef";
-
-- repr = PyString_FromStringAndSize(NULL, 2 + 6*size + 1);
-+ /* Initial allocation is based on the longest-possible unichr
-+ escape.
-+
-+ In wide (UTF-32) builds '\U00xxxxxx' is 10 chars per source
-+ unichr, so in this case it's the longest unichr escape. In
-+ narrow (UTF-16) builds this is five chars per source unichr
-+ since there are two unichrs in the surrogate pair, so in narrow
-+ (UTF-16) builds it's not the longest unichr escape.
-+
-+ In wide or narrow builds '\uxxxx' is 6 chars per source unichr,
-+ so in the narrow (UTF-16) build case it's the longest unichr
-+ escape.
-+ */
-+
-+ repr = PyString_FromStringAndSize(NULL,
-+ 2
-+#ifdef Py_UNICODE_WIDE
-+ + 10*size
-+#else
-+ + 6*size
-+#endif
-+ + 1);
- if (repr == NULL)
- return NULL;
-
-@@ -1995,15 +2016,6 @@
- #ifdef Py_UNICODE_WIDE
- /* Map 21-bit characters to '\U00xxxxxx' */
- else if (ch >= 0x10000) {
-- int offset = p - PyString_AS_STRING(repr);
--
-- /* Resize the string if necessary */
-- if (offset + 12 > PyString_GET_SIZE(repr)) {
-- if (_PyString_Resize(&repr, PyString_GET_SIZE(repr) + 100))
-- return NULL;
-- p = PyString_AS_STRING(repr) + offset;
-- }
--
- *p++ = '\\';
- *p++ = 'U';
- *p++ = hexdigit[(ch >> 28) & 0x0000000F];
-@@ -2016,8 +2028,8 @@
- *p++ = hexdigit[ch & 0x0000000F];
- continue;
- }
--#endif
-- /* Map UTF-16 surrogate pairs to Unicode \UXXXXXXXX escapes */
-+#else
-+ /* Map UTF-16 surrogate pairs to '\U00xxxxxx' */
- else if (ch >= 0xD800 && ch < 0xDC00) {
- Py_UNICODE ch2;
- Py_UCS4 ucs;
-@@ -2042,6 +2054,7 @@
- s--;
- size++;
- }
-+#endif
-
- /* Map 16-bit characters to '\uxxxx' */
- if (ch >= 256) {
diff --git a/lang/python24/files/patch-setup.py b/lang/python24/files/patch-setup.py
index 93e2c278b468..b01b73db560a 100644
--- a/lang/python24/files/patch-setup.py
+++ b/lang/python24/files/patch-setup.py
@@ -1,5 +1,5 @@
---- setup.py.orig Mon Oct 9 22:08:07 2006
-+++ setup.py Mon Oct 9 22:08:42 2006
+--- setup.py.orig Mon Nov 27 03:33:44 2006
++++ setup.py Mon Nov 27 03:35:40 2006
@@ -15,7 +15,7 @@
from distutils.command.install_lib import install_lib
@@ -9,7 +9,7 @@
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
-@@ -425,7 +425,7 @@
+@@ -442,7 +442,7 @@
if self.compiler.find_library_file(lib_dirs, 'readline'):
readline_libs = ['readline']
if self.compiler.find_library_file(lib_dirs,
@@ -18,12 +18,12 @@
readline_libs.append('ncursesw')
elif self.compiler.find_library_file(lib_dirs,
'ncurses'):
-@@ -681,7 +681,7 @@
-
+@@ -728,7 +728,7 @@
# Curses support, requiring the System V version of curses, often
# provided by the ncurses library.
+ panel_library = 'panel'
- if (self.compiler.find_library_file(lib_dirs, 'ncursesw')):
+ if (self.compiler.find_library_file(lib_dirs, 'xxxncursesw')):
curses_libs = ['ncursesw']
- exts.append( Extension('_curses', ['_cursesmodule.c'],
- libraries = curses_libs) )
+ # Bug 1464056: If _curses.so links with ncursesw,
+ # _curses_panel.so must link with panelw.