aboutsummaryrefslogtreecommitdiff
path: root/lang/python24
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2004-02-24 08:19:54 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2004-02-24 08:19:54 +0000
commit1efbe2254e0f2716aa30240bb0c5cab6b41fe2bf (patch)
tree4ce1d3966b275ad57ffb8efbea18c5267c0abdd6 /lang/python24
parent4ceb33798116be3887f9bcb776449aa054824060 (diff)
downloadports-1efbe2254e0f2716aa30240bb0c5cab6b41fe2bf.tar.gz
ports-1efbe2254e0f2716aa30240bb0c5cab6b41fe2bf.zip
Notes
Diffstat (limited to 'lang/python24')
-rw-r--r--lang/python24/Makefile2
-rw-r--r--lang/python24/files/patch-Lib::distutils::spawn.py17
2 files changed, 18 insertions, 1 deletions
diff --git a/lang/python24/Makefile b/lang/python24/Makefile
index cca1766771f9..516eac521283 100644
--- a/lang/python24/Makefile
+++ b/lang/python24/Makefile
@@ -7,7 +7,7 @@
PORTNAME= python
PORTVERSION= 2.3.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
diff --git a/lang/python24/files/patch-Lib::distutils::spawn.py b/lang/python24/files/patch-Lib::distutils::spawn.py
new file mode 100644
index 000000000000..208b10fc1083
--- /dev/null
+++ b/lang/python24/files/patch-Lib::distutils::spawn.py
@@ -0,0 +1,17 @@
+--- Lib/distutils/spawn.py.orig Tue Feb 24 16:55:44 2004
++++ Lib/distutils/spawn.py Tue Feb 24 16:56:01 2004
+@@ -144,7 +144,13 @@
+ # Loop until the child either exits or is terminated by a signal
+ # (ie. keep waiting if it's merely stopped)
+ while 1:
+- (pid, status) = os.waitpid(pid, 0)
++ try:
++ (pid, status) = os.waitpid(pid, 0)
++ except OSError, exc:
++ import errno
++ if exc.errno == errno.EINTR:
++ continue
++ raise exc
+ if os.WIFSIGNALED(status):
+ raise DistutilsExecError, \
+ "command '%s' terminated by signal %d" % \