aboutsummaryrefslogtreecommitdiff
path: root/lang/python24
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2006-08-12 03:57:46 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2006-08-12 03:57:46 +0000
commit773ced5fafb2801decdb7ed2b8330e371f2a9deb (patch)
tree67b4b10433e335f059c6380bbeb83f6a049f8629 /lang/python24
parentc6d89716288a5e0e29a9ff09b9a9d114c2b3d9db (diff)
downloadports-773ced5fafb2801decdb7ed2b8330e371f2a9deb.tar.gz
ports-773ced5fafb2801decdb7ed2b8330e371f2a9deb.zip
Notes
Diffstat (limited to 'lang/python24')
-rw-r--r--lang/python24/files/patch-setup.py22
1 files changed, 20 insertions, 2 deletions
diff --git a/lang/python24/files/patch-setup.py b/lang/python24/files/patch-setup.py
index 7a4e76912d96..0211a6b3556d 100644
--- a/lang/python24/files/patch-setup.py
+++ b/lang/python24/files/patch-setup.py
@@ -1,5 +1,5 @@
---- setup.py.orig Tue Aug 31 10:37:25 2004
-+++ setup.py Fri Sep 3 10:42:53 2004
+--- setup.py.orig Sat Aug 12 12:46:21 2006
++++ setup.py Sat Aug 12 12:47:00 2006
@@ -15,7 +15,7 @@
from distutils.command.install_lib import install_lib
@@ -9,3 +9,21 @@
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
+@@ -425,7 +425,7 @@
+ if self.compiler.find_library_file(lib_dirs, 'readline'):
+ readline_libs = ['readline']
+ if self.compiler.find_library_file(lib_dirs,
+- 'ncursesw'):
++ 'xxxncursesw'):
+ readline_libs.append('ncursesw')
+ elif self.compiler.find_library_file(lib_dirs,
+ 'ncurses'):
+@@ -681,7 +681,7 @@
+
+ # Curses support, requiring the System V version of curses, often
+ # provided by the ncurses library.
+- if (self.compiler.find_library_file(lib_dirs, 'ncursesw')):
++ if (self.compiler.find_library_file(lib_dirs, 'xxxncursesw')):
+ curses_libs = ['ncursesw']
+ exts.append( Extension('_curses', ['_cursesmodule.c'],
+ libraries = curses_libs) )