aboutsummaryrefslogtreecommitdiff
path: root/lang/python26/Makefile
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2013-12-08 08:57:34 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2013-12-08 08:57:34 +0000
commit9b3e3f814b321613e0365cfa4f79a21bcd548f4b (patch)
tree13b499858dedad8acd583a86c75a73189186ca6c /lang/python26/Makefile
parentf9638375416c14549d10fceab83826f29465e3c5 (diff)
Notes
Diffstat (limited to 'lang/python26/Makefile')
-rw-r--r--lang/python26/Makefile27
1 files changed, 15 insertions, 12 deletions
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index af7896702ed2..2a0d0accf118 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -1,28 +1,31 @@
# Created by: Hye-Shik Chang <perky@FreeBSD.org>
# $FreeBSD$
-PORTNAME= python26
-PORTVERSION= 2.6.9
-PORTREVISION= 1
-CATEGORIES= lang python ipv6
-MASTER_SITES= PYTHON
+PORTNAME= python26
+PORTVERSION= 2.6.9
+PORTREVISION= 1
+CATEGORIES= lang python ipv6
+MASTER_SITES= PYTHON
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
-DISTFILES= ${PYTHON_DISTFILE}
+DISTFILES= ${PYTHON_DISTFILE}
+DIST_SUBDIR= python
MAINTAINER= python@FreeBSD.org
COMMENT= Interpreted object-oriented programming language
+LICENSE= PSFL
+
LIB_DEPENDS= libffi.so:${PORTSDIR}/devel/libffi
-DEPRECATED= Python 2.6 is now end-of-life, please migrate to lang/python27
-EXPIRATION_DATE=2014-01-01
+DEPRECATED= Python 2.6 is now end-of-life, please migrate to lang/python27
+EXPIRATION_DATE= 2014-01-01
-DIST_SUBDIR= python
-GNU_CONFIGURE= yes
+GNU_CONFIGURE= yes
CONFIGURE_SCRIPT= ../configure # must be relative
CONFIGURE_ARGS= --with-system-ffi
-CONFIGURE_ENV= SVNVERSION="echo freebsd" ac_cv_opt_olimit_ok=no
-MAKE_ENV= VPATH="${PYTHON_WRKSRC}"
+CONFIGURE_ENV= SVNVERSION="echo freebsd" ac_cv_opt_olimit_ok=no
+MAKE_ENV= VPATH="${PYTHON_WRKSRC}"
+
INSTALL_TARGET= altinstall
MAN1= ${PYTHON_VERSION}.1