aboutsummaryrefslogtreecommitdiff
path: root/lang/python26/files
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2004-09-03 17:12:28 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2004-09-03 17:12:28 +0000
commita8ff97aec34b8e37b7a3c97180f2590959a050d5 (patch)
tree829091ad0bdd245a294079bfcebedb6fdd9d3368 /lang/python26/files
parent1c60fe9d1f1678647ae577193cb2af8804831303 (diff)
Notes
Diffstat (limited to 'lang/python26/files')
-rw-r--r--lang/python26/files/patch-Modules::cjkcodecs::_codecs_iso2022.c123
-rw-r--r--lang/python26/files/patch-configure4
-rw-r--r--lang/python26/files/patch-setup.py15
3 files changed, 5 insertions, 137 deletions
diff --git a/lang/python26/files/patch-Modules::cjkcodecs::_codecs_iso2022.c b/lang/python26/files/patch-Modules::cjkcodecs::_codecs_iso2022.c
deleted file mode 100644
index 3b535c80e42e..000000000000
--- a/lang/python26/files/patch-Modules::cjkcodecs::_codecs_iso2022.c
+++ /dev/null
@@ -1,123 +0,0 @@
---- Modules/cjkcodecs/_codecs_iso2022.c.orig Sun Jul 18 13:34:33 2004
-+++ Modules/cjkcodecs/_codecs_iso2022.c Sat Aug 21 09:07:17 2004
-@@ -2,7 +2,7 @@
- * _codecs_iso2022.c: Codecs collection for ISO-2022 encodings.
- *
- * Written by Hye-Shik Chang <perky@FreeBSD.org>
-- * $CJKCodecs: _codecs_iso2022.c,v 1.18 2004/07/07 18:30:17 perky Exp $
-+ * $CJKCodecs: _codecs_iso2022.c,v 1.22 2004/08/19 17:08:13 perky Exp $
- */
-
- #define USING_IMPORTED_MAPS
-@@ -117,7 +117,7 @@
-
- struct iso2022_config {
- int flags;
-- const struct iso2022_designation designations[]; /* non-ascii desigs */
-+ const struct iso2022_designation *designations; /* non-ascii desigs */
- };
-
- /*-*- iso-2022 codec implementation -*-*/
-@@ -197,7 +197,9 @@
- length = 2;
- #if Py_UNICODE_SIZE == 2
- if (length == 2) {
-- ucs4_t u4in[2] = {IN1, IN2};
-+ ucs4_t u4in[2];
-+ u4in[0] = (ucs4_t)IN1;
-+ u4in[1] = (ucs4_t)IN2;
- encoded = dsg->encoder(u4in, &length);
- } else
- encoded = dsg->encoder(&c, &length);
-@@ -420,7 +422,7 @@
- DECODER(iso2022)
- {
- const struct iso2022_designation *dsgcache = NULL;
--
-+
- while (inleft > 0) {
- unsigned char c = IN1;
- int err;
-@@ -1047,50 +1049,52 @@
- #define REGISTRY_ISO8859_7 { CHARSET_ISO8859_7, 2, 1, \
- NULL, dummy_decoder, dummy_encoder }
- #define REGISTRY_SENTINEL { 0, }
-+#define CONFIGDEF(var, attrs) \
-+ static const struct iso2022_config iso2022_##var##_config = { \
-+ attrs, iso2022_##var##_designations \
-+ };
-
--static const struct iso2022_config iso2022_kr_config = {
-- 0,
-- { REGISTRY_KSX1001, REGISTRY_SENTINEL },
-+static const struct iso2022_designation iso2022_kr_designations[] = {
-+ REGISTRY_KSX1001, REGISTRY_SENTINEL
- };
-+CONFIGDEF(kr, 0)
-
--static const struct iso2022_config iso2022_jp_config = {
-- NO_SHIFT | USE_JISX0208_EXT,
-- { REGISTRY_JISX0208, REGISTRY_JISX0201_R, REGISTRY_JISX0208_O,
-- REGISTRY_SENTINEL },
-+static const struct iso2022_designation iso2022_jp_designations[] = {
-+ REGISTRY_JISX0208, REGISTRY_JISX0201_R, REGISTRY_JISX0208_O,
-+ REGISTRY_SENTINEL
- };
-+CONFIGDEF(jp, NO_SHIFT | USE_JISX0208_EXT)
-
--static const struct iso2022_config iso2022_jp_1_config = {
-- NO_SHIFT | USE_JISX0208_EXT,
-- { REGISTRY_JISX0208, REGISTRY_JISX0212, REGISTRY_JISX0201_R,
-- REGISTRY_JISX0208_O, REGISTRY_SENTINEL },
-+static const struct iso2022_designation iso2022_jp_1_designations[] = {
-+ REGISTRY_JISX0208, REGISTRY_JISX0212, REGISTRY_JISX0201_R,
-+ REGISTRY_JISX0208_O, REGISTRY_SENTINEL
- };
-+CONFIGDEF(jp_1, NO_SHIFT | USE_JISX0208_EXT)
-
--static const struct iso2022_config iso2022_jp_2_config = {
-- NO_SHIFT | USE_G2 | USE_JISX0208_EXT,
-- { REGISTRY_JISX0208, REGISTRY_JISX0212, REGISTRY_KSX1001,
-- REGISTRY_GB2312, REGISTRY_JISX0201_R, REGISTRY_JISX0208_O,
-- REGISTRY_ISO8859_1, REGISTRY_ISO8859_7, REGISTRY_SENTINEL },
-+static const struct iso2022_designation iso2022_jp_2_designations[] = {
-+ REGISTRY_JISX0208, REGISTRY_JISX0212, REGISTRY_KSX1001,
-+ REGISTRY_GB2312, REGISTRY_JISX0201_R, REGISTRY_JISX0208_O,
-+ REGISTRY_ISO8859_1, REGISTRY_ISO8859_7, REGISTRY_SENTINEL
- };
-+CONFIGDEF(jp_2, NO_SHIFT | USE_G2 | USE_JISX0208_EXT)
-
--static const struct iso2022_config iso2022_jp_2004_config = {
-- NO_SHIFT | USE_G2 | USE_JISX0208_EXT,
-- { REGISTRY_JISX0213_2004_1_PAIRONLY, REGISTRY_JISX0208,
-- REGISTRY_JISX0213_2004_1, REGISTRY_JISX0213_2004_2,
-- REGISTRY_SENTINEL },
-+static const struct iso2022_designation iso2022_jp_2004_designations[] = {
-+ REGISTRY_JISX0213_2004_1_PAIRONLY, REGISTRY_JISX0208,
-+ REGISTRY_JISX0213_2004_1, REGISTRY_JISX0213_2004_2, REGISTRY_SENTINEL
- };
-+CONFIGDEF(jp_2004, NO_SHIFT | USE_JISX0208_EXT)
-
--static const struct iso2022_config iso2022_jp_3_config = {
-- NO_SHIFT | USE_JISX0208_EXT,
-- { REGISTRY_JISX0213_2000_1_PAIRONLY, REGISTRY_JISX0208,
-- REGISTRY_JISX0213_2000_1, REGISTRY_JISX0213_2000_2,
-- REGISTRY_SENTINEL },
-+static const struct iso2022_designation iso2022_jp_3_designations[] = {
-+ REGISTRY_JISX0213_2000_1_PAIRONLY, REGISTRY_JISX0208,
-+ REGISTRY_JISX0213_2000_1, REGISTRY_JISX0213_2000_2, REGISTRY_SENTINEL
- };
-+CONFIGDEF(jp_3, NO_SHIFT | USE_JISX0208_EXT)
-
--static const struct iso2022_config iso2022_jp_ext_config = {
-- NO_SHIFT | USE_JISX0208_EXT,
-- { REGISTRY_JISX0208, REGISTRY_JISX0212, REGISTRY_JISX0201_R,
-- REGISTRY_JISX0201_K, REGISTRY_JISX0208_O, REGISTRY_SENTINEL },
-+static const struct iso2022_designation iso2022_jp_ext_designations[] = {
-+ REGISTRY_JISX0208, REGISTRY_JISX0212, REGISTRY_JISX0201_R,
-+ REGISTRY_JISX0201_K, REGISTRY_JISX0208_O, REGISTRY_SENTINEL
- };
-+CONFIGDEF(jp_ext, NO_SHIFT | USE_JISX0208_EXT)
-
-
- BEGIN_MAPPINGS_LIST
diff --git a/lang/python26/files/patch-configure b/lang/python26/files/patch-configure
index 6ee47894e12f..9ed971ab4be7 100644
--- a/lang/python26/files/patch-configure
+++ b/lang/python26/files/patch-configure
@@ -1,7 +1,7 @@
--- configure.orig Sat Oct 4 13:27:50 2003
+++ configure Sat Oct 4 13:29:05 2003
@@ -1321,7 +1321,7 @@
- VERSION=2.3
+ VERSION=2.4
-SOVERSION=1.0
@@ -9,7 +9,7 @@
# The later defininition of _XOPEN_SOURCE disables certain features
# on Linux, so we need _GNU_SOURCE to re-enable them (makedev, tm_zone).
-@@ -3594,6 +3594,12 @@
+@@ -3396,6 +3396,12 @@
LDLIBRARY='libpython$(VERSION).so'
BLDLIBRARY='-L. -lpython$(VERSION)'
RUNSHARED=LD_LIBRARY_PATH=`pwd`:${LD_LIBRARY_PATH}
diff --git a/lang/python26/files/patch-setup.py b/lang/python26/files/patch-setup.py
index acb3015726b9..a94599c261d9 100644
--- a/lang/python26/files/patch-setup.py
+++ b/lang/python26/files/patch-setup.py
@@ -1,5 +1,5 @@
---- setup.py.orig Fri Jul 23 11:50:10 2004
-+++ setup.py Sat Aug 21 09:04:58 2004
+--- setup.py.orig Tue Aug 31 10:37:25 2004
++++ setup.py Fri Sep 3 10:42:53 2004
@@ -15,7 +15,7 @@
from distutils.command.install_lib import install_lib
@@ -9,16 +9,7 @@
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
-@@ -782,7 +782,7 @@
- # Linux-specific modules
- exts.append( Extension('linuxaudiodev', ['linuxaudiodev.c']) )
-
-- if platform in ('linux2', 'freebsd4', 'freebsd5'):
-+ if platform in ('linux2', 'freebsd4', 'freebsd5', 'freebsd6'):
- exts.append( Extension('ossaudiodev', ['ossaudiodev.c']) )
-
- if platform == 'sunos5':
-@@ -1164,8 +1164,7 @@
+@@ -1144,8 +1144,7 @@
ext_modules=[Extension('struct', ['structmodule.c'])],
# Scripts to install