aboutsummaryrefslogtreecommitdiff
path: root/lang/python26
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /lang/python26
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
Notes
Diffstat (limited to 'lang/python26')
-rw-r--r--lang/python26/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index 1f99726da72c..3e19ec12e903 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -23,7 +23,7 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_SCRIPT= ../configure # must be relative
CONFIGURE_ENV= OPT="${CFLAGS}" SVNVERSION="echo freebsd"
MAKE_ENV= VPATH="${PYTHON_WRKSRC}"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
INSTALL_TARGET= altinstall
MAN1= ${PYTHON_VERSION}.1
@@ -132,7 +132,7 @@ pre-patch:
's,/usr/doc/python-docs-,${PREFIX}/share/doc/python,g' \
${PATCH_WRKSRC}/Lib/pydoc.py
${REINPLACE_CMD} -e \
- 's|^\( *prefixes = .*\)\]$$|\1, "${X11BASE}"]|g' \
+ 's|^\( *prefixes = .*\)\]$$|\1, "${LOCALBASE}"]|g' \
${PATCH_WRKSRC}/Lib/site.py
${REINPLACE_CMD} -e \
's|^ \(..ASDLGEN.*\)$$| ${TRUE}|g' \