aboutsummaryrefslogtreecommitdiff
path: root/lang/python27/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-05-31 10:13:55 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-05-31 10:13:55 +0000
commit7e94fe3d3dc571a393df6de7de4b38829b4d5642 (patch)
tree41f506d31a4e74faed1b0394a2a3860eb9185707 /lang/python27/Makefile
parent734ec74d08faf94051421612614a30ac4cbd2bc5 (diff)
downloadports-7e94fe3d3dc571a393df6de7de4b38829b4d5642.tar.gz
ports-7e94fe3d3dc571a393df6de7de4b38829b4d5642.zip
Notes
Diffstat (limited to 'lang/python27/Makefile')
-rw-r--r--lang/python27/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index cf57c895186e..94ed7116127a 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -7,6 +7,7 @@
PORTNAME= python27
PORTVERSION= 2.7.3
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -50,10 +51,10 @@ BINLINKS_SUB= -e 's,smtpd,smtpd${PYTHON_VER},' \
-e 's,(idle|pydoc|python-shared|python),\1${PYTHON_VER},'
OPTIONS_DEFINE= THREADS SEM PTH PYMALLOC IPV6 FPECTL EXAMPLES
-OPTIONS_DEFAULT= THREADS UCS4 PYMALLOC IPV6
+OPTIONS_DEFAULT= THREADS UCS2 PYMALLOC IPV6
OPTIONS_SINGLE= UCS
-OPTIONS_SINGLE_UCS= UCS4 UCS2
+OPTIONS_SINGLE_UCS= UCS2 UCS4
.include <bsd.port.pre.mk>
@@ -106,7 +107,7 @@ CONFIGURE_ARGS+= --enable-unicode=ucs4
CONFIGURE_ARGS+= --enable-unicode=ucs2
.endif
-.if ${PORT_OPTIONS:MPYMALLOC}
+.if empty(PORT_OPTIONS:MPYMALLOC)
CONFIGURE_ARGS+= --without-pymalloc
.endif