aboutsummaryrefslogtreecommitdiff
path: root/lang/python27/Makefile
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2011-09-18 08:33:15 +0000
committerChris Rees <crees@FreeBSD.org>2011-09-18 08:33:15 +0000
commitd03cd9afc5c493cefcf8dc87de3689b53d79a54d (patch)
tree1eb7a0391e3b616f786f85392504dc00fc02c250 /lang/python27/Makefile
parentcc516d16adb1ca25b7ddc0221b98af33e3062f52 (diff)
downloadports-d03cd9afc5c493cefcf8dc87de3689b53d79a54d.tar.gz
ports-d03cd9afc5c493cefcf8dc87de3689b53d79a54d.zip
Notes
Diffstat (limited to 'lang/python27/Makefile')
-rw-r--r--lang/python27/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index d8ee01c78ed3..9e95b226855d 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -136,8 +136,10 @@ MAKE_ENV+= UNAME_m="powerpc64"
CFLAGS+= -DPYTHON_DEFAULT_RECURSION_LIMIT=900
.endif
-.if !exists(/usr/bin/ypcat) # the world with NO_NIS
+# See http://bugs.freebsd.org/115940
+.if !exists(/usr/bin/ypcat) || defined(WITHOUT_NIS) # the world with NO_NIS
PLIST_SUB+= NO_NIS="@comment "
+WITHOUT_NIS?= detected
.else
PLIST_SUB+= NO_NIS=""
.endif
@@ -193,6 +195,11 @@ post-patch:
@cd ${WRKSRC} && ${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-setup.py
.endif
.endif
+.if defined(WITHOUT_NIS)
+ ${REINPLACE_CMD} -e \
+ 's/disabled_module_list =[^]]*/&, "nis"/' \
+ ${PATCH_WRKSRC}/setup.py
+.endif
post-configure:
${TAR} -C ${WRKSRC} -cf - . | ${TAR} -C ${SHARED_WRKSRC} -xf -