aboutsummaryrefslogtreecommitdiff
path: root/lang/python27/files
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2014-12-22 09:45:37 +0000
committerMarcus von Appen <mva@FreeBSD.org>2014-12-22 09:45:37 +0000
commit130b6117585677ef7549e26d73a1d384f001b466 (patch)
tree26c7e2acb3897f80879b97f5720f81d5f70e1a43 /lang/python27/files
parent76768e87ede6580d2a93cf4ec18db9c670139ef9 (diff)
downloadports-130b6117585677ef7549e26d73a1d384f001b466.tar.gz
ports-130b6117585677ef7549e26d73a1d384f001b466.zip
Notes
Diffstat (limited to 'lang/python27/files')
-rw-r--r--lang/python27/files/patch-Modules-_ctypes-libffi-configure25
-rw-r--r--lang/python27/files/patch-issue2116674
2 files changed, 7 insertions, 92 deletions
diff --git a/lang/python27/files/patch-Modules-_ctypes-libffi-configure b/lang/python27/files/patch-Modules-_ctypes-libffi-configure
index 096e58002326..fa315597a7ea 100644
--- a/lang/python27/files/patch-Modules-_ctypes-libffi-configure
+++ b/lang/python27/files/patch-Modules-_ctypes-libffi-configure
@@ -1,22 +1,11 @@
---- Modules/_ctypes/libffi/configure.orig 2010-03-19 19:59:20.000000000 +0100
-+++ Modules/_ctypes/libffi/configure 2011-03-06 09:20:16.000000000 +0100
-@@ -6289,7 +6289,7 @@
+--- Modules/_ctypes/libffi/configure.orig 2014-12-16 08:10:12.000000000 +0100
++++ Modules/_ctypes/libffi/configure 2014-12-16 08:10:40.000000000 +0100
+@@ -7526,7 +7526,7 @@
rm -rf conftest*
;;
--x86_64-*kfreebsd*-gnu|x86_64-*linux*|ppc*-*linux*|powerpc*-*linux*| \
-+amd64-*-freebsd*|x86_64-*kfreebsd*-gnu|x86_64-*linux*|ppc*-*linux*|powerpc*-*linux*| \
+-x86_64-*kfreebsd*-gnu|x86_64-*linux*|powerpc*-*linux*| \
++amd64-*-freebsd*|x86_64-*kfreebsd*-gnu|x86_64-*linux*|powerpc*-*linux*| \
s390*-*linux*|s390*-*tpf*|sparc*-*linux*)
- # Find out which ABI we are using.
- echo 'int i;' > conftest.$ac_ext
-@@ -11275,6 +11275,9 @@
- powerpc-*-freebsd*)
- TARGET=POWERPC_FREEBSD; TARGETDIR=powerpc
- ;;
-+ powerpc64-*-freebsd*)
-+ TARGET=POWERPC; TARGETDIR=powerpc
-+ ;;
- powerpc*-*-rtems*)
- TARGET=POWERPC; TARGETDIR=powerpc
- ;;
-
+ # Find out what ABI is being produced by ac_compile, and set linker
+ # options accordingly. Note that the listed cases only cover the
diff --git a/lang/python27/files/patch-issue21166 b/lang/python27/files/patch-issue21166
deleted file mode 100644
index ec6c3ada03ec..000000000000
--- a/lang/python27/files/patch-issue21166
+++ /dev/null
@@ -1,74 +0,0 @@
-# HG changeset patch
-# User Ned Deily <nad@acm.org>
-# Date 1408739459 25200
-# Node ID edb6b282469ea0e8f819d0310afb2937b59dd6b9
-# Parent 727fd4ead3fd854e900ed89362714ad1f7434e5a
-Issue #21166: Prevent possible segfaults and other random failures of
-python --generate-posix-vars in pybuilddir.txt build target by ensuring
-that pybuilddir.txt is always regenerated when configure is run and
-that the newly built skeleton python does not inadvertently import
-modules from previously installed instances.
-
-diff --git a/Makefile.pre.in b/Makefile.pre.in
---- Makefile.pre.in
-+++ Makefile.pre.in
-@@ -447,8 +447,18 @@ platform: $(BUILDPYTHON) pybuilddir.txt
- # Create build directory and generate the sysconfig build-time data there.
- # pybuilddir.txt contains the name of the build dir and is used for
- # sys.path fixup -- see Modules/getpath.c.
-+# Since this step runs before shared modules are built, try to avoid bootstrap
-+# problems by creating a dummy pybuildstr.txt just to allow interpreter
-+# initialization to succeed. It will be overwritten by generate-posix-vars
-+# or removed in case of failure.
- pybuilddir.txt: $(BUILDPYTHON)
-- $(RUNSHARED) $(PYTHON_FOR_BUILD) -S -m sysconfig --generate-posix-vars
-+ @echo "none" > ./pybuilddir.txt
-+ $(RUNSHARED) $(PYTHON_FOR_BUILD) -S -m sysconfig --generate-posix-vars ;\
-+ if test $$? -ne 0 ; then \
-+ echo "generate-posix-vars failed" ; \
-+ rm -f ./pybuilddir.txt ; \
-+ exit 1 ; \
-+ fi
-
- # Build the shared modules
- # Under GNU make, MAKEFLAGS are sorted and normalized; the 's' for
-diff --git a/Misc/NEWS b/Misc/NEWS
---- Misc/NEWS
-+++ Misc/NEWS
-@@ -120,6 +120,9 @@ Build
- - Issue #15759: "make suspicious", "make linkcheck" and "make doctest" in Doc/
- now display special message when and only when there are failures.
-
-+- Issue #21166: Prevent possible segfaults and other random failures of
-+ python --generate-posix-vars in pybuilddir.txt build target.
-+
- Windows
- -------
-
-diff --git a/configure b/configure
---- configure
-+++ configure
-@@ -2857,6 +2857,9 @@ case $host_os in *\ *) host_os=`echo "$h
-
-
-
-+# pybuilddir.txt will be created by --generate-posix-vars in the Makefile
-+rm -f pybuilddir.txt
-+
- if test "$cross_compiling" = yes; then
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for python interpreter for cross build" >&5
- $as_echo_n "checking for python interpreter for cross build... " >&6; }
-diff --git a/configure.ac b/configure.ac
---- configure.ac
-+++ configure.ac
-@@ -16,6 +16,9 @@ AC_CANONICAL_HOST
- AC_SUBST(build)
- AC_SUBST(host)
-
-+# pybuilddir.txt will be created by --generate-posix-vars in the Makefile
-+rm -f pybuilddir.txt
-+
- if test "$cross_compiling" = yes; then
- AC_MSG_CHECKING([for python interpreter for cross build])
- if test -z "$PYTHON_FOR_BUILD"; then
-