aboutsummaryrefslogtreecommitdiff
path: root/lang/python27
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2016-07-03 00:10:42 +0000
committerWen Heping <wen@FreeBSD.org>2016-07-03 00:10:42 +0000
commit427fad8f42c93d25a85ac98021c4d84f418aa413 (patch)
tree20e7c0ea278774dc2d9fe0f859e69cf61dc3aca1 /lang/python27
parent2cb4f8c1bf0bf6c87f070c5612307e1b4c9899ae (diff)
downloadports-427fad8f42c93d25a85ac98021c4d84f418aa413.tar.gz
ports-427fad8f42c93d25a85ac98021c4d84f418aa413.zip
- Update to version 2.7.12
- Remove patch that is included upstream - Switch USE_OPENSSL to USES= ssl [1] - Update documentation for python27 - Don't set CPE_VERSION, default is PORTVERSION [1] PR: 210685 Submitted by: wen@(myself), brnrd@ [1] Exp-run by: antoine Differential Revision: https://reviews.freebsd.org/D6994
Notes
Notes: svn path=/head/; revision=417945
Diffstat (limited to 'lang/python27')
-rw-r--r--lang/python27/Makefile5
-rw-r--r--lang/python27/Makefile.version2
-rw-r--r--lang/python27/distinfo5
-rw-r--r--lang/python27/files/patch-Modules_zipimport.c17
-rw-r--r--lang/python27/pkg-plist34
5 files changed, 24 insertions, 39 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 2167013870f5..76fa9e6ca380 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -2,7 +2,6 @@
PORTNAME= python27
PORTVERSION= ${PYTHON_PORTVERSION}
-PORTREVISION= 3
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
DISTNAME= Python-${PORTVERSION}
@@ -13,14 +12,12 @@ COMMENT= Interpreted object-oriented programming language
LICENSE= PSFL
-USES= cpe ncurses pkgconfig readline tar:xz
+USES= cpe ncurses pkgconfig readline ssl tar:xz
USE_LDCONFIG= yes
-USE_OPENSSL= yes
GNU_CONFIGURE= yes
CPE_VENDOR= python
CPE_PRODUCT= ${CPE_VENDOR}
-CPE_VERSION= ${PORTVERSION}
CONFIGURE_ARGS+= --enable-shared
CONFIGURE_ENV+= ac_cv_opt_olimit_ok=no OPT="" # Null out OPT to respect user CFLAGS and remove optimizations
diff --git a/lang/python27/Makefile.version b/lang/python27/Makefile.version
index 88ff2ad0d784..6ae1f49fbb2d 100644
--- a/lang/python27/Makefile.version
+++ b/lang/python27/Makefile.version
@@ -1,4 +1,4 @@
# Mk/Uses/python.mk includes this file, don't remove it!
# $FreeBSD$
-PYTHON_PORTVERSION= 2.7.11
+PYTHON_PORTVERSION= 2.7.12
diff --git a/lang/python27/distinfo b/lang/python27/distinfo
index b6ee725bfb46..a70d5fc6f122 100644
--- a/lang/python27/distinfo
+++ b/lang/python27/distinfo
@@ -1,2 +1,3 @@
-SHA256 (python/Python-2.7.11.tar.xz) = 962b4c45af50124ea61f11a30deb4342fc0bc21126790fa1d7f6c79809413f46
-SIZE (python/Python-2.7.11.tar.xz) = 12277476
+TIMESTAMP = 1467158541
+SHA256 (python/Python-2.7.12.tar.xz) = d7837121dd5652a05fef807c361909d255d173280c4e1a4ded94d73d80a1f978
+SIZE (python/Python-2.7.12.tar.xz) = 12390820
diff --git a/lang/python27/files/patch-Modules_zipimport.c b/lang/python27/files/patch-Modules_zipimport.c
deleted file mode 100644
index aaf69496fedd..000000000000
--- a/lang/python27/files/patch-Modules_zipimport.c
+++ /dev/null
@@ -1,17 +0,0 @@
-
-Bug: http://bugs.python.org/issue26171
-
---- Modules/zipimport.c.orig 2015-12-05 19:47:16 UTC
-+++ Modules/zipimport.c
-@@ -895,6 +895,11 @@ get_data(char *archive, PyObject *toc_en
- PyMarshal_ReadShortFromFile(fp); /* local header size */
- file_offset += l; /* Start of file data */
-
-+ if (data_size > LONG_MAX - 1) {
-+ fclose(fp);
-+ PyErr_NoMemory();
-+ return NULL;
-+ }
- raw_data = PyString_FromStringAndSize((char *)NULL, compress == 0 ?
- data_size : data_size + 1);
- if (raw_data == NULL) {
diff --git a/lang/python27/pkg-plist b/lang/python27/pkg-plist
index 34bcf2f12727..e039ee48bdae 100644
--- a/lang/python27/pkg-plist
+++ b/lang/python27/pkg-plist
@@ -1436,8 +1436,8 @@ lib/python2.7/ensurepip/__init__.pyo
lib/python2.7/ensurepip/__main__.py
lib/python2.7/ensurepip/__main__.pyc
lib/python2.7/ensurepip/__main__.pyo
-lib/python2.7/ensurepip/_bundled/pip-7.1.2-py2.py3-none-any.whl
-lib/python2.7/ensurepip/_bundled/setuptools-18.2-py2.py3-none-any.whl
+lib/python2.7/ensurepip/_bundled/pip-8.1.1-py2.py3-none-any.whl
+lib/python2.7/ensurepip/_bundled/setuptools-20.10.1-py2.py3-none-any.whl
lib/python2.7/ensurepip/_uninstall.py
lib/python2.7/ensurepip/_uninstall.pyc
lib/python2.7/ensurepip/_uninstall.pyo
@@ -1729,12 +1729,18 @@ lib/python2.7/idlelib/idle_test/test_configdialog.pyo
lib/python2.7/idlelib/idle_test/test_delegator.py
lib/python2.7/idlelib/idle_test/test_delegator.pyo
lib/python2.7/idlelib/idle_test/test_delegator.pyc
+lib/python2.7/idlelib/idle_test/test_editmenu.py
+lib/python2.7/idlelib/idle_test/test_editmenu.pyo
+lib/python2.7/idlelib/idle_test/test_editmenu.pyc
lib/python2.7/idlelib/idle_test/test_formatparagraph.py
lib/python2.7/idlelib/idle_test/test_formatparagraph.pyo
lib/python2.7/idlelib/idle_test/test_formatparagraph.pyc
lib/python2.7/idlelib/idle_test/test_grep.py
lib/python2.7/idlelib/idle_test/test_grep.pyo
lib/python2.7/idlelib/idle_test/test_grep.pyc
+lib/python2.7/idlelib/idle_test/test_helpabout.py
+lib/python2.7/idlelib/idle_test/test_helpabout.pyo
+lib/python2.7/idlelib/idle_test/test_helpabout.pyc
lib/python2.7/idlelib/idle_test/test_hyperparser.py
lib/python2.7/idlelib/idle_test/test_hyperparser.pyo
lib/python2.7/idlelib/idle_test/test_hyperparser.pyc
@@ -2723,13 +2729,12 @@ lib/python2.7/test/badsyntax_future7.py
lib/python2.7/test/badsyntax_future8.py
lib/python2.7/test/badsyntax_future9.py
lib/python2.7/test/badsyntax_nocaret.py
-lib/python2.7/test/buffer_tests.py
-lib/python2.7/test/buffer_tests.pyo
-lib/python2.7/test/buffer_tests.pyc
+lib/python2.7/test/capath/0e4015b9.0
lib/python2.7/test/capath/4e1295a3.0
lib/python2.7/test/capath/5ed36f99.0
lib/python2.7/test/capath/6e88d7b8.0
lib/python2.7/test/capath/99d0fa06.0
+lib/python2.7/test/capath/ce7b8643.0
lib/python2.7/test/cfgparser.1
lib/python2.7/test/check_soundcard.vbs
lib/python2.7/test/cmath_testcases.txt
@@ -2929,7 +2934,6 @@ lib/python2.7/test/gdb_sample.py
lib/python2.7/test/gdb_sample.pyo
lib/python2.7/test/gdb_sample.pyc
lib/python2.7/test/greyrgb.uue
-lib/python2.7/test/https_svn_python_org_root.pem
lib/python2.7/test/ieee754.txt
lib/python2.7/test/imghdrdata/python.bmp
lib/python2.7/test/imghdrdata/python.gif
@@ -3252,9 +3256,6 @@ lib/python2.7/test/test_codecs.pyc
lib/python2.7/test/test_codeop.py
lib/python2.7/test/test_codeop.pyo
lib/python2.7/test/test_codeop.pyc
-lib/python2.7/test/test_coding.py
-lib/python2.7/test/test_coding.pyo
-lib/python2.7/test/test_coding.pyc
lib/python2.7/test/test_coercion.py
lib/python2.7/test/test_coercion.pyo
lib/python2.7/test/test_coercion.pyc
@@ -3770,6 +3771,9 @@ lib/python2.7/test/test_operator.pyc
lib/python2.7/test/test_optparse.py
lib/python2.7/test/test_optparse.pyo
lib/python2.7/test/test_optparse.pyc
+lib/python2.7/test/test_ordered_dict.py
+lib/python2.7/test/test_ordered_dict.pyo
+lib/python2.7/test/test_ordered_dict.pyc
lib/python2.7/test/test_os.py
lib/python2.7/test/test_os.pyo
lib/python2.7/test/test_os.pyc
@@ -3788,15 +3792,9 @@ lib/python2.7/test/test_peepholer.pyc
lib/python2.7/test/test_pep247.py
lib/python2.7/test/test_pep247.pyo
lib/python2.7/test/test_pep247.pyc
-lib/python2.7/test/test_pep263.py
-lib/python2.7/test/test_pep263.pyo
-lib/python2.7/test/test_pep263.pyc
lib/python2.7/test/test_pep277.py
lib/python2.7/test/test_pep277.pyo
lib/python2.7/test/test_pep277.pyc
-lib/python2.7/test/test_pep292.py
-lib/python2.7/test/test_pep292.pyo
-lib/python2.7/test/test_pep292.pyc
lib/python2.7/test/test_pep352.py
lib/python2.7/test/test_pep352.pyo
lib/python2.7/test/test_pep352.pyc
@@ -3980,6 +3978,9 @@ lib/python2.7/test/test_softspace.pyc
lib/python2.7/test/test_sort.py
lib/python2.7/test/test_sort.pyo
lib/python2.7/test/test_sort.pyc
+lib/python2.7/test/test_source_encoding.py
+lib/python2.7/test/test_source_encoding.pyo
+lib/python2.7/test/test_source_encoding.pyc
lib/python2.7/test/test_spwd.py
lib/python2.7/test/test_spwd.pyo
lib/python2.7/test/test_spwd.pyc
@@ -4127,6 +4128,9 @@ lib/python2.7/test/test_ttk_textonly.pyc
lib/python2.7/test/test_tuple.py
lib/python2.7/test/test_tuple.pyo
lib/python2.7/test/test_tuple.pyc
+lib/python2.7/test/test_turtle.py
+lib/python2.7/test/test_turtle.pyo
+lib/python2.7/test/test_turtle.pyc
lib/python2.7/test/test_typechecks.py
lib/python2.7/test/test_typechecks.pyo
lib/python2.7/test/test_typechecks.pyc