aboutsummaryrefslogtreecommitdiff
path: root/lang/python27
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2012-12-21 15:45:29 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2012-12-21 15:45:29 +0000
commit10277be714285a829695087454af943a5c114cb7 (patch)
tree1ce0a1d9c78a5f204de6da3d283e7d4286e31882 /lang/python27
parent0309ba97629f2c608f2e2c6643414d771ce6a2c3 (diff)
downloadports-10277be714285a829695087454af943a5c114cb7.tar.gz
ports-10277be714285a829695087454af943a5c114cb7.zip
Notes
Diffstat (limited to 'lang/python27')
-rw-r--r--lang/python27/Makefile7
-rw-r--r--lang/python27/pkg-plist2
2 files changed, 8 insertions, 1 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index cc09a246266c..346383dbba97 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -7,7 +7,7 @@
PORTNAME= python27
PORTVERSION= 2.7.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -37,6 +37,7 @@ SHARED_WRKSRC= ${PYTHON_WRKSRC}/portbld.shared
PLIST= ${WRKDIR}/PLIST
PLIST_TEMPLATE?=${PKGDIR}/pkg-plist
PLIST_SUB= PYVER=${PYTHON_VERSION:S/python//} \
+ PYMAJOR=${PYTHON_MAJOR_VER} \
PYVER_WITHPAT=${PORTVERSION:S/.c/c/}
EXAMPLESDIR= ${PREFIX}/share/examples/${PYTHON_VERSION}
DATADIR= ${PREFIX}/share/${PYTHON_VERSION}
@@ -287,6 +288,10 @@ post-install:
done
.endif
+.for file in python python-config
+ cd ${LOCALBASE}/bin && ${LN} -sf ${file:S/python/${PYTHON_VERSION}/} ${file:S/python/python${PYTHON_MAJOR_VER}/}
+.endfor
+
.if !defined(NOPORTDATA)
@${MKDIR} ${DATADIR}
@cd ${PYTHON_WRKSRC}; ${TAR} -cf - Tools | \
diff --git a/lang/python27/pkg-plist b/lang/python27/pkg-plist
index ce9a979f2105..28e2f38fd799 100644
--- a/lang/python27/pkg-plist
+++ b/lang/python27/pkg-plist
@@ -6,8 +6,10 @@ bin/idle%%PYVER%%
%%IF_DEFAULT%%bin/pydoc
bin/pydoc%%PYVER%%
%%IF_DEFAULT%%bin/python
+bin/python%%PYMAJOR%%
bin/python%%PYVER%%
%%IF_DEFAULT%%bin/python-config
+bin/python%%PYMAJOR%%-config
bin/python%%PYVER%%-config
%%IF_DEFAULT%%bin/python-shared
bin/python-shared%%PYVER%%