aboutsummaryrefslogtreecommitdiff
path: root/lang/python27
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2012-06-14 06:02:52 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2012-06-14 06:02:52 +0000
commit2b56d23731b916af46b365b8f7f641e157015ff0 (patch)
tree9346c20336aaae9a9aa700ac4899f17439aeb5ef /lang/python27
parent2e9fd03cd50e2468a08e8b5f9cd4799f2cded070 (diff)
downloadports-2b56d23731b916af46b365b8f7f641e157015ff0.tar.gz
ports-2b56d23731b916af46b365b8f7f641e157015ff0.zip
Notes
Diffstat (limited to 'lang/python27')
-rw-r--r--lang/python27/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 75ebf61a2d18..2b9458b5b6f6 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -146,6 +146,12 @@ CONFIGURE_ARGS+= --disable-ipv6
CONFIGURE_ARGS+= --with-fpectl
.endif
+post-extract:
+# The distribution tarball for python 2.7 has permission bits for 'others'
+# set to 0. Later during install, we copy Tools and Demo to the installed
+# prefix, so set them right here.
+ ${CHMOD} -R og=u-w ${PYTHON_WRKSRC}/Tools ${PYTHON_WRKSRC}/Demo
+
pre-patch:
${CP} -r ${PATCH_WRKSRC}/Lib/plat-freebsd8 \
${PATCH_WRKSRC}/Lib/plat-freebsd9
@@ -267,12 +273,12 @@ post-install:
.if !defined(NOPORTDATA)
@${MKDIR} ${DATADIR}
@cd ${PYTHON_WRKSRC}; ${TAR} -cf - Tools | \
- (cd ${DATADIR}; ${TAR} -xf -)
+ (cd ${DATADIR}; ${TAR} --no-same-owner -xf -)
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
@cd ${PYTHON_WRKSRC}/Demo; ${TAR} -cf - * | \
- (cd ${EXAMPLESDIR}; ${TAR} -xf -)
+ (cd ${EXAMPLESDIR}; ${TAR} --no-same-owner -xf -)
.endif
@${CAT} ${PKGMESSAGE}