aboutsummaryrefslogtreecommitdiff
path: root/lang/python27
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2014-11-04 09:14:21 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2014-11-04 09:14:21 +0000
commitaa02163c1401bdc8a1cfa11181a8f5011555220c (patch)
tree0555c114031e18e9bc04687858ab96a799454247 /lang/python27
parent34a129dd14c8c39e8406bfa0b6f5898877fc6a45 (diff)
downloadports-aa02163c1401bdc8a1cfa11181a8f5011555220c.tar.gz
ports-aa02163c1401bdc8a1cfa11181a8f5011555220c.zip
Notes
Diffstat (limited to 'lang/python27')
-rw-r--r--lang/python27/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index f6d54bc96ad3..4c3cd7ca6c5e 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -2,7 +2,7 @@
PORTNAME= python27
PORTVERSION= 2.7.8
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
@@ -34,8 +34,8 @@ PLIST_SUB= ABI=${ABIFLAGS} \
PORTVERSION=${PORTVERSION} \
OSMAJOR=${OSVERSION:C/([0-9]*)[0-9]{5}/\1/} # For plat-freebsd* in pkg-plist. http://bugs.python.org/issue19554
-OPTIONS_DEFINE= DEBUG IPV6 NLS PYMALLOC SEM THREADS
-OPTIONS_DEFAULT= IPV6 NLS PYMALLOC SEM THREADS UCS4
+OPTIONS_DEFINE= DEBUG IPV6 NLS PYMALLOC SEM THREADS LIBFFI
+OPTIONS_DEFAULT= IPV6 NLS PYMALLOC SEM THREADS UCS4 LIBFFI
OPTIONS_SINGLE= UNICODE
OPTIONS_SINGLE_UNICODE= UCS2 UCS4
@@ -45,6 +45,7 @@ NLS_DESC= Enable gettext support for the locale module
UCS2_DESC= Enable UCS2 Unicode Strings
UCS4_DESC= Enable UCS4 Unicode Strings
PYMALLOC_DESC= Enable specialized mallocs
+LIBFFI_DESC= Use libffi from ports instead of bundled version
DEBUG_CONFIGURE_WITH= pydebug
IPV6_CONFIGURE_ENABLE= ipv6
@@ -88,6 +89,11 @@ MAKE_ENV+= UNAME_m="powerpc64"
CFLAGS+= -DPYTHON_DEFAULT_RECURSION_LIMIT=900
.endif
+.if ${PORT_OPTIONS:MLIBFFI}
+CONFIGURE_ARGS+= --with-system-ffi
+LIB_DEPENDS+= libffi.so:${PORTSDIR}/devel/libffi
+.endif
+
# See http://bugs.freebsd.org/115940
.if !exists(/usr/bin/ypcat) || defined(WITHOUT_NIS) # the world with NO_NIS
PLIST_SUB+= NO_NIS="@comment "