aboutsummaryrefslogtreecommitdiff
path: root/lang/python27
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2011-10-27 09:56:58 +0000
committerErwin Lansing <erwin@FreeBSD.org>2011-10-27 09:56:58 +0000
commitd7364df9690460afc9ff73146b56658451f225b6 (patch)
tree9757c7d56e96f9f67f9829d775eae8647b92be95 /lang/python27
parentdda0d7bb1ff5ffaf12321f4352f3476f826e97f8 (diff)
downloadports-d7364df9690460afc9ff73146b56658451f225b6.tar.gz
ports-d7364df9690460afc9ff73146b56658451f225b6.zip
Notes
Diffstat (limited to 'lang/python27')
-rw-r--r--lang/python27/Makefile13
-rw-r--r--lang/python27/files/extra-patch-setup.py4
-rw-r--r--lang/python27/files/patch-Lib-test-test_fcntl.py2
-rw-r--r--lang/python27/files/patch-Lib-test-test_threading.py2
-rw-r--r--lang/python27/files/patch-setup.py26
-rw-r--r--lang/python27/pkg-plist3
6 files changed, 32 insertions, 18 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 6803069c26e8..4730839f8665 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -39,7 +39,8 @@ PLIST_SUB= PYVER=${PYTHON_VERSION:S/python//} \
EXAMPLESDIR= ${PREFIX}/share/examples/${PYTHON_VERSION}
DATADIR= ${PREFIX}/share/${PYTHON_VERSION}
-PLATFORMS= plat-freebsd6 plat-freebsd7 plat-freebsd8 plat-freebsd9
+PLATFORMS= plat-freebsd6 plat-freebsd7 plat-freebsd8 plat-freebsd9 \
+ plat-freebsd10
BIN_SCRIPTS= 2to3 idle pydoc smtpd.py
BIN_FILES= python python-shared python-config python-shared-config \
@@ -148,6 +149,8 @@ CONFIGURE_ARGS+= --with-fpectl
pre-patch:
${CP} -r ${PATCH_WRKSRC}/Lib/plat-freebsd8 \
${PATCH_WRKSRC}/Lib/plat-freebsd9
+ ${CP} -r ${PATCH_WRKSRC}/Lib/plat-freebsd8 \
+ ${PATCH_WRKSRC}/Lib/plat-freebsd10
${MKDIR} ${WRKSRC} ${SHARED_WRKSRC}/Modules
${LN} ${PATCH_WRKSRC}/Lib/smtpd.py ${PATCH_WRKSRC}/Tools/scripts/
.for script in ${BIN_SCRIPTS}
@@ -192,6 +195,14 @@ post-patch:
${PATCH_WRKSRC}/setup.py
.endif
+pre-configure:
+ @${REINPLACE_CMD} -e 's|freebsd1\*)|freebsd1\.\*)|' \
+ -e 's|freebsd2\*)|freebsd2\.\*)|' \
+ -e 's|freebsd\[123\]\*)|freebsd\[123\]\.\*)|' \
+ -e 's|freebsd\[\[123\]\]\*)|freebsd\[\[123\]\]\.\*)|' \
+ ${PATCH_WRKSRC}/Modules/_ctypes/libffi/m4/libtool.m4 \
+ ${PATCH_WRKSRC}/Modules/_ctypes/libffi/configure
+
post-configure:
${TAR} -C ${WRKSRC} -cf - . | ${TAR} -C ${SHARED_WRKSRC} -xf -
${LN} -sf ${PYTHON_WRKSRC}/Lib ${WRKSRC}/Lib
diff --git a/lang/python27/files/extra-patch-setup.py b/lang/python27/files/extra-patch-setup.py
index 8deaa316c01e..98fd1a8b3621 100644
--- a/lang/python27/files/extra-patch-setup.py
+++ b/lang/python27/files/extra-patch-setup.py
@@ -4,7 +4,7 @@
macros = dict()
libraries = []
-- elif platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9'):
+- elif platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10'):
+ elif platform in ('freebsd4', 'freebsd5', 'freebsd6'):
# FreeBSD's P1003.1b semaphore support is very experimental
# and has many known problems. (as of June 2008)
@@ -16,7 +16,7 @@
+ )
+ libraries = []
+
-+ elif platform in ('freebsd7', 'freebsd8', 'freebsd9'):
++ elif platform in ('freebsd7', 'freebsd8', 'freebsd9', 'freebsd10'):
+ macros = dict( # FreeBSD 7+
+ HAVE_SEM_OPEN=1,
+ HAVE_SEM_TIMEDWAIT=1,
diff --git a/lang/python27/files/patch-Lib-test-test_fcntl.py b/lang/python27/files/patch-Lib-test-test_fcntl.py
index ebd2ec81265f..f8773e0aaf1c 100644
--- a/lang/python27/files/patch-Lib-test-test_fcntl.py
+++ b/lang/python27/files/patch-Lib-test-test_fcntl.py
@@ -5,7 +5,7 @@
'Darwin1.2', 'darwin',
'freebsd2', 'freebsd3', 'freebsd4', 'freebsd5',
- 'freebsd6', 'freebsd7', 'freebsd8',
-+ 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9',
++ 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10'
'bsdos2', 'bsdos3', 'bsdos4',
'openbsd', 'openbsd2', 'openbsd3', 'openbsd4'):
if struct.calcsize('l') == 8:
diff --git a/lang/python27/files/patch-Lib-test-test_threading.py b/lang/python27/files/patch-Lib-test-test_threading.py
index e6e0647806c7..0f9c791c9e01 100644
--- a/lang/python27/files/patch-Lib-test-test_threading.py
+++ b/lang/python27/files/patch-Lib-test-test_threading.py
@@ -5,7 +5,7 @@
# Skip platforms with known problems forking from a worker thread.
# See http://bugs.python.org/issue3863.
- if sys.platform in ('freebsd4', 'freebsd5', 'freebsd6', 'netbsd5',
-+ if sys.platform in ('freebsd6', 'freebsd7', 'freebsd8', 'freebsd9','netbsd5',
++ if sys.platform in ('freebsd6', 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10', 'netbsd5',
'os2emx'):
print >>sys.stderr, ('Skipping test_3_join_in_forked_from_thread'
' due to known OS bugs on'), sys.platform
diff --git a/lang/python27/files/patch-setup.py b/lang/python27/files/patch-setup.py
index 6c3470873905..f793c0bb19f1 100644
--- a/lang/python27/files/patch-setup.py
+++ b/lang/python27/files/patch-setup.py
@@ -1,5 +1,5 @@
---- setup.py.orig 2010-06-27 20:36:16.000000000 +0800
-+++ setup.py 2010-09-03 09:23:13.000000000 +0800
+--- setup.py.orig 2011-06-11 17:46:28.000000000 +0200
++++ setup.py 2011-10-18 12:05:34.000000000 +0200
@@ -21,7 +21,7 @@
COMPILED_WITH_PYDEBUG = hasattr(sys, 'gettotalrefcount')
@@ -9,7 +9,7 @@
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
-@@ -608,7 +608,7 @@
+@@ -642,7 +642,7 @@
# use the same library for the readline and curses modules.
if 'curses' in readline_termcap_library:
curses_library = readline_termcap_library
@@ -18,7 +18,7 @@
curses_library = 'ncursesw'
elif self.compiler.find_library_file(lib_dirs, 'ncurses'):
curses_library = 'ncurses'
-@@ -647,7 +647,7 @@
+@@ -681,7 +681,7 @@
'termcap'):
readline_libs.append('termcap')
exts.append( Extension('readline', ['readline.c'],
@@ -27,7 +27,7 @@
extra_link_args=readline_extra_link_args,
libraries=readline_libs) )
else:
-@@ -749,6 +749,8 @@
+@@ -783,6 +783,8 @@
# OpenSSL doesn't do these until 0.9.8 so we'll bring our own hash
exts.append( Extension('_sha256', ['sha256module.c']) )
exts.append( Extension('_sha512', ['sha512module.c']) )
@@ -36,7 +36,7 @@
# Modules that provide persistent dictionary-like semantics. You will
# probably want to arrange for at least one of them to be available on
-@@ -1086,7 +1088,7 @@
+@@ -1120,7 +1122,7 @@
sysroot = macosx_sdk_root()
f = os.path.join(sysroot, f[1:])
@@ -45,7 +45,7 @@
data = open(f).read()
m = re.search(r"#s*define\s+HASHVERSION\s+2\s*", data)
if m is not None:
-@@ -1212,12 +1214,13 @@
+@@ -1246,12 +1248,13 @@
# provided by the ncurses library.
panel_library = 'panel'
if curses_library.startswith('ncurses'):
@@ -60,7 +60,7 @@
libraries = curses_libs) )
elif curses_library == 'curses' and platform != 'darwin':
# OSX has an old Berkeley curses, not good enough for
-@@ -1230,6 +1233,7 @@
+@@ -1264,6 +1267,7 @@
curses_libs = ['curses']
exts.append( Extension('_curses', ['_cursesmodule.c'],
@@ -68,25 +68,25 @@
libraries = curses_libs) )
else:
missing.append('_curses')
-@@ -1398,7 +1402,7 @@
+@@ -1432,7 +1436,7 @@
macros = dict()
libraries = []
- elif platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8'):
-+ elif platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9'):
++ elif platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10'):
# FreeBSD's P1003.1b semaphore support is very experimental
# and has many known problems. (as of June 2008)
macros = dict()
-@@ -1450,7 +1454,7 @@
+@@ -1484,7 +1488,7 @@
missing.append('linuxaudiodev')
if (platform in ('linux2', 'freebsd4', 'freebsd5', 'freebsd6',
- 'freebsd7', 'freebsd8')
-+ 'freebsd7', 'freebsd8', 'freebsd9')
++ 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10')
or platform.startswith("gnukfreebsd")):
exts.append( Extension('ossaudiodev', ['ossaudiodev.c']) )
else:
-@@ -2032,9 +2036,7 @@
+@@ -2066,9 +2070,7 @@
ext_modules=[Extension('_struct', ['_struct.c'])],
# Scripts to install
diff --git a/lang/python27/pkg-plist b/lang/python27/pkg-plist
index 716ff6ff53f5..272a7741daf3 100644
--- a/lang/python27/pkg-plist
+++ b/lang/python27/pkg-plist
@@ -986,6 +986,8 @@ lib/lib%%PYTHON_VERSION%%.so.1
%%PYTHON_LIBDIR%%/plat-freebsd8/regen
%%PYTHON_LIBDIR%%/plat-freebsd9/IN.py
%%PYTHON_LIBDIR%%/plat-freebsd9/regen
+%%PYTHON_LIBDIR%%/plat-freebsd10/IN.py
+%%PYTHON_LIBDIR%%/plat-freebsd10/regen
%%PYTHON_LIBDIR%%/platform.py
%%PYTHON_LIBDIR%%/plistlib.py
%%PYTHON_LIBDIR%%/popen2.py
@@ -2367,6 +2369,7 @@ lib/libpython2.7.a
@dirrm %%PYTHON_LIBDIR%%/sqlite3
@dirrm %%PYTHON_LIBDIR%%/site-packages
@dirrm %%PYTHON_LIBDIR%%/pydoc_data
+@dirrm %%PYTHON_LIBDIR%%/plat-freebsd10
@dirrm %%PYTHON_LIBDIR%%/plat-freebsd9
@dirrm %%PYTHON_LIBDIR%%/plat-freebsd8
@dirrm %%PYTHON_LIBDIR%%/plat-freebsd7