aboutsummaryrefslogtreecommitdiff
path: root/lang/python27
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2016-06-17 17:09:04 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2016-06-17 17:09:04 +0000
commit5643ed620ad357da5eeacb8833b77c6f2d7747ac (patch)
tree0adb184f75003084e164df487438ff3c51107f45 /lang/python27
parentb7700753f9278cb149b133ca845a9609bb3408ef (diff)
downloadports-5643ed620ad357da5eeacb8833b77c6f2d7747ac.tar.gz
ports-5643ed620ad357da5eeacb8833b77c6f2d7747ac.zip
Notes
Diffstat (limited to 'lang/python27')
-rw-r--r--lang/python27/Makefile2
-rw-r--r--lang/python27/files/patch-Modules_zipimport.c17
2 files changed, 18 insertions, 1 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 6806e1d27391..2167013870f5 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -2,7 +2,7 @@
PORTNAME= python27
PORTVERSION= ${PYTHON_PORTVERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
DISTNAME= Python-${PORTVERSION}
diff --git a/lang/python27/files/patch-Modules_zipimport.c b/lang/python27/files/patch-Modules_zipimport.c
new file mode 100644
index 000000000000..aaf69496fedd
--- /dev/null
+++ b/lang/python27/files/patch-Modules_zipimport.c
@@ -0,0 +1,17 @@
+
+Bug: http://bugs.python.org/issue26171
+
+--- Modules/zipimport.c.orig 2015-12-05 19:47:16 UTC
++++ Modules/zipimport.c
+@@ -895,6 +895,11 @@ get_data(char *archive, PyObject *toc_en
+ PyMarshal_ReadShortFromFile(fp); /* local header size */
+ file_offset += l; /* Start of file data */
+
++ if (data_size > LONG_MAX - 1) {
++ fclose(fp);
++ PyErr_NoMemory();
++ return NULL;
++ }
+ raw_data = PyString_FromStringAndSize((char *)NULL, compress == 0 ?
+ data_size : data_size + 1);
+ if (raw_data == NULL) {