aboutsummaryrefslogtreecommitdiff
path: root/lang/python27
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2017-06-28 02:37:53 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2017-06-28 02:37:53 +0000
commita4046066e99a0f93c06ce0ab11954a5ee8506e0c (patch)
treed2b4ddfd03e7b70d56574342bf5a5d811bb76dc0 /lang/python27
parented163be5e0941b5bdd17322f4a18ad4c3a7b680f (diff)
downloadports-a4046066e99a0f93c06ce0ab11954a5ee8506e0c.tar.gz
ports-a4046066e99a0f93c06ce0ab11954a5ee8506e0c.zip
Notes
Diffstat (limited to 'lang/python27')
-rw-r--r--lang/python27/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index b77e4ec62215..0280eea82ddc 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -2,7 +2,7 @@
PORTNAME= python27
PORTVERSION= ${PYTHON_PORTVERSION}
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
DISTNAME= Python-${PORTVERSION}
@@ -15,7 +15,7 @@ LICENSE= PSFL
BROKEN_SSL= openssl-devel
-USES= cpe ncurses pathfix pkgconfig readline ssl tar:xz shebangfix
+USES= cpe ncurses pathfix pkgconfig readline:port ssl tar:xz shebangfix
PATHFIX_MAKEFILEIN= Makefile.pre.in
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -115,6 +115,13 @@ PLIST_SUB+= NO_NIS=""
.endif
post-patch:
+# readline shared library is present on base before FreeBSD 11 - r268461
+# force setup.py ignore base and use readline from ports
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1100000
+ ${REINPLACE_CMD} -e \
+ "s|lib_dirs,\ \'readline\'|[\'${LOCALBASE}/lib\',\ \'.\'],\ \'readline\'|" \
+ ${WRKSRC}/setup.py
+.endif
${REINPLACE_CMD} -e 's|/usr/local/bin/python|${python_CMD}|' \
${WRKSRC}/Lib/cgi.py
@${REINPLACE_CMD} -e \