aboutsummaryrefslogtreecommitdiff
path: root/lang/python27
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2012-06-19 17:48:42 +0000
committerMarcus von Appen <mva@FreeBSD.org>2012-06-19 17:48:42 +0000
commitb89f9ab26fccada9c70fe861c8ffcaab2f707dbc (patch)
tree028a8def266da5996c596eb375a356ff8ca9d697 /lang/python27
parent83bc131ec156b6d0ae945f9310352a37923d7052 (diff)
downloadports-b89f9ab26fccada9c70fe861c8ffcaab2f707dbc.tar.gz
ports-b89f9ab26fccada9c70fe861c8ffcaab2f707dbc.zip
Notes
Diffstat (limited to 'lang/python27')
-rw-r--r--lang/python27/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index ccf765ed6be3..c03236a92af5 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -50,12 +50,14 @@ BINLINKS_SUB= -e 's,smtpd,smtpd${PYTHON_VER},' \
-e 's,2to3,2to3-${PYTHON_VER},' \
-e 's,(idle|pydoc|python-shared|python),\1${PYTHON_VER},'
-OPTIONS_DEFINE= THREADS SEM PTH PYMALLOC IPV6 FPECTL EXAMPLES
+OPTIONS_DEFINE= THREADS SEM PTH PYMALLOC IPV6 FPECTL EXAMPLES NLS
OPTIONS_DEFAULT= THREADS UCS4 PYMALLOC IPV6
OPTIONS_SINGLE= UCS
OPTIONS_SINGLE_UCS= UCS2 UCS4
+NLS_DESC= Enable Gettext support for the locale module
+
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MSEM}
@@ -78,6 +80,14 @@ PLIST_SUB+= IF_DEFAULT=""
PLIST_SUB+= IF_DEFAULT="@comment "
.endif
+.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT= yes
+LDFLAGS+= "-L${LOCALBASE}/lib"
+CFLAGS+= "-I${LOCALBASE}/include"
+.else
+CONFIGURE_ENV+= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
+.endif
+
.if ${PORT_OPTIONS:MTHREADS}
PLIST_SUB+= THREADS=""
.if ${PORT_OPTIONS:MPTH}