aboutsummaryrefslogtreecommitdiff
path: root/lang/python30/files/patch-setup.py
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2006-08-10 10:05:13 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2006-08-10 10:05:13 +0000
commitdf0b95301ad1855a5e560611ee09667a4cc3f8b9 (patch)
tree2d5e949e1e51d87d90e94f98cd40f1e5dae51a62 /lang/python30/files/patch-setup.py
parentc301a34f24386d71f55689751024c05cda3f4557 (diff)
downloadports-df0b95301ad1855a5e560611ee09667a4cc3f8b9.tar.gz
ports-df0b95301ad1855a5e560611ee09667a4cc3f8b9.zip
Notes
Diffstat (limited to 'lang/python30/files/patch-setup.py')
-rw-r--r--lang/python30/files/patch-setup.py15
1 files changed, 12 insertions, 3 deletions
diff --git a/lang/python30/files/patch-setup.py b/lang/python30/files/patch-setup.py
index ebf70e88cb39..cf0beedab0c6 100644
--- a/lang/python30/files/patch-setup.py
+++ b/lang/python30/files/patch-setup.py
@@ -1,5 +1,5 @@
---- setup.py.orig Tue Jun 6 08:38:06 2006
-+++ setup.py Fri Jun 23 11:02:35 2006
+--- setup.py.orig Fri Jun 30 15:18:39 2006
++++ setup.py Thu Aug 10 18:41:33 2006
@@ -15,7 +15,7 @@
from distutils.command.install_lib import install_lib
@@ -9,7 +9,16 @@
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
-@@ -1470,8 +1470,7 @@
+@@ -590,6 +590,8 @@
+ # OpenSSL doesn't do these until 0.9.8 so we'll bring our own hash
+ exts.append( Extension('_sha256', ['sha256module.c']) )
+ exts.append( Extension('_sha512', ['sha512module.c']) )
++ else:
++ open('.without_own_sha', 'w')
+
+
+ # Modules that provide persistent dictionary-like semantics. You will
+@@ -1498,8 +1500,7 @@
ext_modules=[Extension('_struct', ['_struct.c'])],
# Scripts to install