aboutsummaryrefslogtreecommitdiff
path: root/lang/python31/Makefile
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2011-09-18 08:33:15 +0000
committerChris Rees <crees@FreeBSD.org>2011-09-18 08:33:15 +0000
commitd03cd9afc5c493cefcf8dc87de3689b53d79a54d (patch)
tree1eb7a0391e3b616f786f85392504dc00fc02c250 /lang/python31/Makefile
parentcc516d16adb1ca25b7ddc0221b98af33e3062f52 (diff)
downloadports-d03cd9afc5c493cefcf8dc87de3689b53d79a54d.tar.gz
ports-d03cd9afc5c493cefcf8dc87de3689b53d79a54d.zip
Notes
Diffstat (limited to 'lang/python31/Makefile')
-rw-r--r--lang/python31/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/lang/python31/Makefile b/lang/python31/Makefile
index 0650170d3525..9389dfa372fb 100644
--- a/lang/python31/Makefile
+++ b/lang/python31/Makefile
@@ -96,8 +96,10 @@ CONFIGURE_ARGS+= --without-pymalloc
CFLAGS+= -DPYTHON_DEFAULT_RECURSION_LIMIT=900
.endif
-.if !exists(/usr/bin/ypcat) # the world with NO_NIS
+# See http://bugs.freebsd.org/115940
+.if !exists(/usr/bin/ypcat) || defined(WITHOUT_NIS) # the world with NO_NIS
PLIST_SUB+= NO_NIS="@comment "
+WITHOUT_NIS?= detected
.else
PLIST_SUB+= NO_NIS=""
.endif
@@ -143,6 +145,13 @@ pre-patch:
${ECHO} "fpectl fpectlmodule.c" >> ${WRKSRC}/Modules/Setup.dist
.endif
+post-patch:
+.if defined(WITHOUT_NIS)
+ ${REINPLACE_CMD} -e \
+ 's/disabled_module_list =[^]]*/&, "nis"/' \
+ ${PATCH_WRKSRC}/setup.py
+.endif
+
post-configure:
${TAR} -C ${WRKSRC} -cf - . | ${TAR} -C ${SHARED_WRKSRC} -xf -
${LN} -sf ${PYTHON_WRKSRC}/Lib ${WRKSRC}/Lib