aboutsummaryrefslogtreecommitdiff
path: root/lang/python31/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2001-05-02 11:25:02 +0000
committerThomas Gellekum <tg@FreeBSD.org>2001-05-02 11:25:02 +0000
commita0e827ef6c52f2b527245711de0827a89d0e5f63 (patch)
tree7890a87ce2b64b6d483790401e8ff1bb33066d27 /lang/python31/Makefile
parent6d658404adc5eecf75693f9a0b51873c99d3ba61 (diff)
downloadports-a0e827ef6c52f2b527245711de0827a89d0e5f63.tar.gz
ports-a0e827ef6c52f2b527245711de0827a89d0e5f63.zip
Notes
Diffstat (limited to 'lang/python31/Makefile')
-rw-r--r--lang/python31/Makefile68
1 files changed, 11 insertions, 57 deletions
diff --git a/lang/python31/Makefile b/lang/python31/Makefile
index 3a8b9a65514d..de5bacfac88a 100644
--- a/lang/python31/Makefile
+++ b/lang/python31/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= python
-PORTVERSION= 2.0
+PORTVERSION= 2.1
CATEGORIES= lang python
-MASTER_SITES= http://www.python.org/ftp/python/2.0/ \
- http://SunSITE.Informatik.RWTH-Aachen.DE/python/ftp/python/2.0/
+MASTER_SITES= http://www.python.org/ftp/python/${PORTVERSION}/ \
+ http://SunSITE.Informatik.RWTH-Aachen.DE/python/ftp/python/${PORTVERSION}/
DISTFILES= ${PYTHON_DISTFILE}
MAINTAINER?= tg@FreeBSD.org
@@ -20,19 +20,13 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
INSTALL_TARGET= install
-PLIST= ${WRKDIR}/PLIST
MAN1= python.1
USE_PYTHON= yes
-PYTHON_VERSION= python2.0
+PYTHON_VERSION= python2.1
PYTHON_NO_DEPENDS= yes
#
-# The standard setup file
-#
-SETUP_FILE= Setup
-
-#
# If you don't want to use Python's thread module, you need to set
# WITHOUT_THREADS.
#
@@ -45,43 +39,7 @@ CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS} ${LDFLAGS}"
CONFIGURE_ARGS+= --without-threads
.endif
-#
-# OpenSSL support is built on machines that have it
-#
-.if exists(/etc/ssl/openssl.cnf)
-SETUP_LOCAL+= Setup.OpenSSL
-.endif
-
-#
-# The mpz module is built on machines with a full source tree
-#
-.if exists(/usr/src/contrib/libgmp/gmp-impl.h)
-SETUP_LOCAL+= Setup.gmp
-PLIST_GMP= ${PKGDIR}/pkg-plist.gmp
-.endif
-
-#
-# Install the Tools by default. It contains scripts ranging from an IDE
-# to a web tree checker, to a collection of simple scripts that are useful
-# while extending or managing Python.
-#
-.if !defined(WITHOUT_TOOLS)
-PLIST_TOOLS= ${PKGDIR}/pkg-plist.Tools
-.endif
-
-#
-# Install Demo/ by default.
-#
-.if !defined(WITHOUT_DEMO)
-PLIST_DEMO= ${PKGDIR}/pkg-plist.Demo
-DEMODIR= ${PREFIX}/share/examples/python
-.endif
-
-post-configure:
- ${CP} ${FILESDIR}/${SETUP_FILE} ${WRKSRC}/Modules/Setup
-.for file in ${SETUP_LOCAL}
- ${CAT} ${FILESDIR}/${file} >> ${WRKSRC}/Modules/Setup.local
-.endfor
+DEMODIR= ${PREFIX}/share/examples/${PYTHON_VERSION}
.include <bsd.port.pre.mk>
@@ -92,10 +50,10 @@ CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
.endif
.if ${OSVERSION} >= 500000 && ${OSVERSION} < 500005
-CONFIGURE_ARGS+= --with-libs='-lxpg4'
+CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
.if ${OSVERSION} < 400020
-CONFIGURE_ARGS+= --with-libs='-lxpg4'
+CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
.if ${OSVERSION} >= 500000
@@ -110,24 +68,20 @@ PLATFORMS=plat-freebsd3 plat-freebsd4 plat-freebsd5
pre-install:
.for platform in ${PLATFORMS}
- ${MKDIR} ${PREFIX}/lib/${PYTHON_VERSION}/${platform}
-.for file in FCNTL.py IN.py SOCKET.py TERMIOS.py regen
+ ${MKDIR} ${PYTHON_LIBDIR}/${platform}
+.for file in FCNTL.py IN.py regen
${INSTALL_DATA} ${WRKSRC}/Lib/${platform}/${file} \
- ${PREFIX}/lib/${PYTHON_VERSION}/${platform}/
+ ${PYTHON_LIBDIR}/${platform}/
.endfor
.endfor
- @sort -r -o ${PLIST} ${PLIST_GMP} ${PLIST_TOOLS} ${PLIST_DEMO} ${PKGDIR}/pkg-plist
post-install:
- strip ${PREFIX}/bin/python
@${MKDIR} ${PREFIX}/share/emacs/site-lisp
${INSTALL_DATA} ${WRKSRC}/Misc/python-mode.el ${PREFIX}/share/emacs/site-lisp
@${MKDIR} ${PYTHON_SITELIBDIR}
-.if !defined(WITHOUT_TOOLS)
+.if !defined(NOPORTDOCS)
@cd ${WRKSRC}; tar -c --exclude='*CVS*' -f - Tools | \
(cd ${PYTHON_LIBDIR}; tar xf -)
-.endif
-.if !defined(WITHOUT_DEMO)
@${MKDIR} ${DEMODIR}
@cd ${WRKSRC}/Demo; tar -c --exclude='*CVS*' -f - * | \
(cd ${DEMODIR}; tar xf -)