aboutsummaryrefslogtreecommitdiff
path: root/lang/python31
diff options
context:
space:
mode:
authorBeat Gaetzi <beat@FreeBSD.org>2011-10-28 10:42:24 +0000
committerBeat Gaetzi <beat@FreeBSD.org>2011-10-28 10:42:24 +0000
commit5bc148fb49f344096c1b58fc5cdea109d4171688 (patch)
treeb26aba1dddb29650efab7491684c395baaeaccbc /lang/python31
parent250c73a74b44026f858451128b6b5514e522249d (diff)
downloadports-5bc148fb49f344096c1b58fc5cdea109d4171688.tar.gz
ports-5bc148fb49f344096c1b58fc5cdea109d4171688.zip
Notes
Diffstat (limited to 'lang/python31')
-rw-r--r--lang/python31/Makefile6
-rw-r--r--lang/python31/files/patch-Lib-test-test_fcntl.py2
-rw-r--r--lang/python31/files/patch-Lib-test_regrtest.py7
-rw-r--r--lang/python31/files/patch-setup.py4
-rw-r--r--lang/python31/pkg-plist3
5 files changed, 15 insertions, 7 deletions
diff --git a/lang/python31/Makefile b/lang/python31/Makefile
index 3b262749ac10..ccd3a9aa10fb 100644
--- a/lang/python31/Makefile
+++ b/lang/python31/Makefile
@@ -24,6 +24,7 @@ CONFIGURE_ENV= OPT="${CFLAGS}" SVNVERSION="echo freebsd"
MAKE_ENV= VPATH="${PYTHON_WRKSRC}"
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
+WITH_FBSD10_FIX= yes
INSTALL_TARGET= altinstall
MAN1= ${PYTHON_VERSION}.1
@@ -40,7 +41,8 @@ EXAMPLESDIR= ${PREFIX}/share/examples/${PYTHON_VERSION}
DATADIR= ${PREFIX}/share/${PYTHON_VERSION}
PLATFORMS= plat-freebsd4 plat-freebsd5 plat-freebsd6 \
- plat-freebsd7 plat-freebsd8 plat-freebsd9
+ plat-freebsd7 plat-freebsd8 plat-freebsd9 \
+ plat-freebsd10
BIN_SCRIPTS= 2to3 idle3 pydoc3
BIN_FILES= python python-shared python-config python-shared-config \
@@ -109,6 +111,8 @@ CONFIGURE_ARGS+= --with-fpectl
pre-patch:
${CP} -r ${PATCH_WRKSRC}/Lib/plat-freebsd8 \
${PATCH_WRKSRC}/Lib/plat-freebsd9
+ ${CP} -r ${PATCH_WRKSRC}/Lib/plat-freebsd8 \
+ ${PATCH_WRKSRC}/Lib/plat-freebsd10
${MKDIR} ${WRKSRC} ${SHARED_WRKSRC}/Modules
.for script in ${BIN_SCRIPTS}
${SED} -e '1s,^.*$$,#!${PREFIX}/bin/${PYTHON_VERSION},' \
diff --git a/lang/python31/files/patch-Lib-test-test_fcntl.py b/lang/python31/files/patch-Lib-test-test_fcntl.py
index 62104a2da20e..606a6e9a9612 100644
--- a/lang/python31/files/patch-Lib-test-test_fcntl.py
+++ b/lang/python31/files/patch-Lib-test-test_fcntl.py
@@ -5,7 +5,7 @@
'Darwin1.2', 'darwin',
'freebsd2', 'freebsd3', 'freebsd4', 'freebsd5',
- 'freebsd6', 'freebsd7', 'freebsd8',
-+ 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9',
++ 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10',
'bsdos2', 'bsdos3', 'bsdos4',
'openbsd', 'openbsd2', 'openbsd3', 'openbsd4'):
if struct.calcsize('l') == 8:
diff --git a/lang/python31/files/patch-Lib-test_regrtest.py b/lang/python31/files/patch-Lib-test_regrtest.py
index d10cb99056e6..99754f75043e 100644
--- a/lang/python31/files/patch-Lib-test_regrtest.py
+++ b/lang/python31/files/patch-Lib-test_regrtest.py
@@ -1,10 +1,11 @@
---- Lib/test/regrtest.py.orgi 2009-11-26 13:29:08.000000000 +0100
-+++ Lib/test/regrtest.py 2009-11-26 13:29:37.000000000 +0100
-@@ -1146,6 +1146,7 @@
+--- Lib/test/regrtest.py.orig 2011-06-11 17:48:50.000000000 +0200
++++ Lib/test/regrtest.py 2011-10-28 11:17:37.000000000 +0200
+@@ -1203,6 +1203,8 @@
_expectations['freebsd6'] = _expectations['freebsd4']
_expectations['freebsd7'] = _expectations['freebsd4']
_expectations['freebsd8'] = _expectations['freebsd4']
+_expectations['freebsd9'] = _expectations['freebsd4']
++_expectations['freebsd10'] = _expectations['freebsd4']
class _ExpectedSkips:
def __init__(self):
diff --git a/lang/python31/files/patch-setup.py b/lang/python31/files/patch-setup.py
index ee5430f79091..70983b7f89b1 100644
--- a/lang/python31/files/patch-setup.py
+++ b/lang/python31/files/patch-setup.py
@@ -64,7 +64,7 @@
libraries = []
- elif platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8'):
-+ elif platform in ('freebsd6', 'freebsd7', 'freebsd8', 'freebsd9'):
++ elif platform in ('freebsd6', 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10'):
# FreeBSD's P1003.1b semaphore support is very experimental
# and has many known problems. (as of June 2008)
macros = dict()
@@ -74,7 +74,7 @@
# Platform-specific libraries
- if platform in ('linux2', 'freebsd4', 'freebsd5', 'freebsd6',
- 'freebsd7', 'freebsd8'):
-+ if platform in ('linux2', 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9'):
++ if platform in ('linux2', 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10'):
exts.append( Extension('ossaudiodev', ['ossaudiodev.c']) )
else:
missing.append('ossaudiodev')
diff --git a/lang/python31/pkg-plist b/lang/python31/pkg-plist
index a40334f4dab5..52d8d909749f 100644
--- a/lang/python31/pkg-plist
+++ b/lang/python31/pkg-plist
@@ -899,6 +899,8 @@ libdata/pkgconfig/python-3.1.pc
%%PYTHON_LIBDIR%%/plat-freebsd8/regen
%%PYTHON_LIBDIR%%/plat-freebsd9/IN.py
%%PYTHON_LIBDIR%%/plat-freebsd9/regen
+%%PYTHON_LIBDIR%%/plat-freebsd10/IN.py
+%%PYTHON_LIBDIR%%/plat-freebsd10/regen
%%PYTHON_LIBDIR%%/platform.py
%%PYTHON_LIBDIR%%/plistlib.py
%%PYTHON_LIBDIR%%/poplib.py
@@ -2215,6 +2217,7 @@ libdata/pkgconfig/python-3.1.pc
@dirrm %%PYTHON_LIBDIR%%/sqlite3
@dirrm %%PYTHON_LIBDIR%%/site-packages
@dirrm %%PYTHON_LIBDIR%%/pydoc_data
+@dirrm %%PYTHON_LIBDIR%%/plat-freebsd10
@dirrm %%PYTHON_LIBDIR%%/plat-freebsd9
@dirrm %%PYTHON_LIBDIR%%/plat-freebsd8
@dirrm %%PYTHON_LIBDIR%%/plat-freebsd7