aboutsummaryrefslogtreecommitdiff
path: root/lang/python31
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2013-09-08 14:05:18 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2013-09-08 14:05:18 +0000
commitec7259ec32019cae99f130a03185186ec12aced7 (patch)
tree6d7fe992f675eda5ec64a27474e0fe9678c0334d /lang/python31
parentd4049d4eef52babcf80ecfbdcbeb7db5298c4651 (diff)
downloadports-ec7259ec32019cae99f130a03185186ec12aced7.tar.gz
ports-ec7259ec32019cae99f130a03185186ec12aced7.zip
Notes
Diffstat (limited to 'lang/python31')
-rw-r--r--lang/python31/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/lang/python31/Makefile b/lang/python31/Makefile
index c6f47e13aaca..88dbec3fc95c 100644
--- a/lang/python31/Makefile
+++ b/lang/python31/Makefile
@@ -2,7 +2,7 @@
PORTNAME= python31
PORTVERSION= 3.1.5
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -19,7 +19,7 @@ WRKSRC= ${PYTHON_WRKSRC}/portbld.static
PATCH_WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
CONFIGURE_SCRIPT= ../configure # must be relative
-CONFIGURE_ENV= OPT="${CFLAGS}" SVNVERSION="echo freebsd"
+CONFIGURE_ENV= OPT="" SVNVERSION="echo freebsd"
MAKE_ENV= VPATH="${PYTHON_WRKSRC}"
USE_LDCONFIG= yes
INSTALL_TARGET= altinstall
@@ -58,9 +58,11 @@ NLS_DESC= Enable Gettext support for the locale module
.if ${PORT_OPTIONS:MNLS}
USES+= gettext
-# XXX do not set any LDFLAGS or CFLAGS - this causes pyexpat to fail building
-#LDFLAGS+= "-L${LOCALBASE}/lib"
-#CFLAGS+= "-I${LOCALBASE}/include"
+LDFLAGS+= -L${LOCALBASE}/lib
+# We use CPPFLAGS over CFLAGS here due to -I ordering causing things like
+# elementtree and pyexpat to break with python27, or to silence preprocessor
+# complaints with python33
+CPPFLAGS+= -I${LOCALBASE}/include
.else
CONFIGURE_ENV+= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
.endif