aboutsummaryrefslogtreecommitdiff
path: root/lang/python31
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-03-29 16:35:19 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-03-29 16:35:19 +0000
commit4ca0e60800b90ba4a6de31beabeee8ccce611649 (patch)
tree8324ab31f68eba587c532d238cd3f502d0a56322 /lang/python31
parent7530f93a62fb8bcd686d08f2bfa5dc0f623f3c73 (diff)
downloadports-4ca0e60800b90ba4a6de31beabeee8ccce611649.tar.gz
ports-4ca0e60800b90ba4a6de31beabeee8ccce611649.zip
Notes
Diffstat (limited to 'lang/python31')
-rw-r--r--lang/python31/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/python31/Makefile b/lang/python31/Makefile
index 06e31e8b738e..3a8b9a65514d 100644
--- a/lang/python31/Makefile
+++ b/lang/python31/Makefile
@@ -39,8 +39,8 @@ SETUP_FILE= Setup
LIBC_R!= /sbin/ldconfig -r | grep c_r || true
.if (${LIBC_R} != "") && !defined(WITHOUT_THREADS)
CONFIGURE_ARGS+= --with-threads
-CFLAGS+= -D_THREAD_SAFE
-CONFIGURE_ENV+= LDFLAGS="-pthread ${LDFLAGS}"
+CFLAGS+= ${PTHREAD_CFLAGS}
+CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS} ${LDFLAGS}"
.else
CONFIGURE_ARGS+= --without-threads
.endif