aboutsummaryrefslogtreecommitdiff
path: root/lang/python32/Makefile
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2012-06-19 17:48:42 +0000
committerMarcus von Appen <mva@FreeBSD.org>2012-06-19 17:48:42 +0000
commitb89f9ab26fccada9c70fe861c8ffcaab2f707dbc (patch)
tree028a8def266da5996c596eb375a356ff8ca9d697 /lang/python32/Makefile
parent83bc131ec156b6d0ae945f9310352a37923d7052 (diff)
downloadports-b89f9ab26fccada9c70fe861c8ffcaab2f707dbc.tar.gz
ports-b89f9ab26fccada9c70fe861c8ffcaab2f707dbc.zip
Notes
Diffstat (limited to 'lang/python32/Makefile')
-rw-r--r--lang/python32/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index c0e33286ebcf..041c3e747a9a 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -51,9 +51,11 @@ BIN_FILES= python python-shared python-config python-shared-config \
BINLINKS_SUB= -e 's,(2to3|idle3|pydoc3),\1-${PYTHON_VER},' \
-e 's,(python-shared|python),\1${PYTHON_VER},'
-OPTIONS_DEFINE= THREADS UCS4 PYMALLOC IPV6 FPECTL EXAMPLES
+OPTIONS_DEFINE= THREADS UCS4 PYMALLOC IPV6 FPECTL EXAMPLES NLS
OPTIONS_DEFAULT= THREADS UCS4 PYMALLOC IPV6
+NLS_DESC= Enable Gettext support for the locale module
+
.include <bsd.port.pre.mk>
.if ${PYTHON_VERSION} == ${PYTHON_DEFAULT_VERSION} || !exists(${LOCALBASE}/bin/python)
@@ -63,6 +65,14 @@ PLIST_SUB+= IF_DEFAULT=""
PLIST_SUB+= IF_DEFAULT="@comment "
.endif
+.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT= yes
+LDFLAGS+= "-L${LOCALBASE}/lib"
+CFLAGS+= "-I${LOCALBASE}/include"
+.else
+CONFIGURE_ENV+= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
+.endif
+
.if ${PORT_OPTIONS:MTHREADS}
PLIST_SUB+= THREADS=""
CONFIGURE_ARGS+= --with-threads